I cant drop any game saves into horizon please help meee

please if there is any body out there that can help me pleasse any advice will be greatly appreciated. i downloaded horizon but when every i try to drop a saved game like black ops mod game save file it shows a black circle symbol with a line in the middle i cant drop anything in horizon whyy?

Are you running Horizon as Administrator? If you are, don’t.

Are you sure it’s not in a .zip or .rar container? If it is, extract it and try again.

If you post a link to the save we can check it out for you.

okaye this is it:http://www.mediafire.com/file/keutrv4pb7kks7t/DTZ+Black+Ops+1+Zombies+Mod.zip


and no i dont beleive im run as administator i am using the administrator account to open it and stuff and i already disabled uac and still no luck:(

Does the file look like this on your desktop?

If it does, it’s a compressed .zip or .rar container. Download the WinRAR version that matches your OS from the link below and install it, and then extract the file from it. You will then be able to drag & drop the extracted save/mod menu file into Horizon.

WinRAR: http://www.rarlab.com/download.htm

no it look like a folder with a zipper on it do i have to pay for that rar program?


Not if you dont want to.

yea im a bit of a cheap man lol

can i download a possible cracked version? @MrPrecise

WinRAR can open those file too, and it’s a free trial that you can keep using forever. Have you tried right clicking on it yet to see if it will let you extract from it? Your PC might have 7-Zip or some other software that can extract it for you.

im going to try right now my computor is being extra slow for some reason

7-Zip is free too. http://www.7-zip.org/

Probably, but even the trial version goes out. The only thing that is different with the trail and the paid version is this.

Thats the only thing that would be in your way. Then you click the X and you can be on with your day.

stupid me thank you guys for being fast and responsive to my problem it turns out all i needed to do was unzip lol im sorry but thank you @SteveWonda @MrPrecise