I can't use Infinity

I recently uninstalled infinity and tried to downgrade your program now I can’t use the 2.0 version either, what’s da deal I’m using Win 10 x64-bit Alienware X51 R3

Please try to re-download INFINITY from scratch. Do you get any ERROR message, when you launch the app ?

Make sure to temporarily disable your AntiVirus, as well as any Firewall software on your PC. Remove ALL previous traces of the installed Infinity app on your system (use a REG cleaner tool, if need be).

Go to the following location and path, and manually delete both the “Daring Development” and “Infinity” folders, if they are still there.

C:\Users\Your- Windows USERNAME\AppData\local\Daring Development, as well as C:\Users\Your- Windows USERNAME\AppData\local\Infinity.

Check the TEMP folder as well.

Give this a try. Update to the latest version, once again. Try to re-download INFINITY from this link. The stub should update things:


Remove the old version files as well.

What do you mean exactly by can’t use v2?

Thanks, worked like a dream, just had 2 run ccleaner on my registry