ICARUS Cheats and Trainer for Steam

easy crafting not working, after the new update of the game is not working

same here.

Easy craft not work more, today game receive update

easy craft stopped working

1 Like

Easy Craft is still a no-go as of now

can you guys plz fix the easy craft skill. still not working. thx

4 Likes

The ICARUS cheats have been updated!

Changes:

  • Bug fixes and game compatibility improvements
2 Likes

F10 Craft is not working. I even tried remapping it to Number Pad 0 but it still didn’t work.

cheats not activated wemod cant see the game but i choose manuel game exe and then play on wemod while game playing is activated but cheats cant activated
when try activate a cheat fastest activated and deactivated

The infinite health cheat seems to have been missed for the last 2-3 updates. It makes you invincible, but it also makes most bosses and bears invincible too. The really wired thing is if you de-activate the cheat, as expected you now take damage, but the bears remain invincible. As i say this issue has persisted for the last 2-3 updates, im suppressed no one else has mentioned it.

Have you activated the ‘Unlimited Durability’ option? There’s a note mentioning that some animals’ health is linked to that mod, especially since you mentioned that you’ve already deactivated the ‘Unlimited Health’ mod. https://imgur.com/hBQ8six

1 Like

Legit, how i missed that i will never know. But yes that solved the issue, appreciated bud.

1 Like

Strange problem. I uninstalled and reinstalled Icarus to a faster drive. Updated the game to build 2.1.10.118570. Now none of the Wemod “mods” work for Icarus. Before all the mods worked on the other drive with the 2.1.10.118570 build. Moved from 5400rpm sata to 4x4 nvme m.2 ssd.

Dec 28 update: If I have unlimited health on, the repair hammer won’t repair. Turn off unlimited health and the repairs to the building can be made. I don’t use any other mods.

None of the options seem to be working anymore for me

I just used the trainer, and the mods are still working. Have you checked if you’re using the latest trainer?

it dont work for me why? please fix it says solo only but how do you get into solo? and do you play offline or online?

Hello. Just set the Lobby Setting to ‘Private’.
https://imgur.com/rhtlk0D
https://imgur.com/njlaVSt

1 Like

Thank you so much it work’s :blush::blush::blush::blush::blush::blush::blush::blush:

ya but also i cant save the mods in pro? im a pro user and they still dont save… :frowning: