App Horizon

I'm having a problem opening horizon

I keep having a problem with opening horizon where I try opening it, but nothing happenes. Not even the logo comes up. Also, keep in mind that I am on windows 10.

Welcome to the community!

First thing to do is to run Horizon in compatibility mode for Windows 7:

Then just click ‘Apply’ and try launching again.

Let us know if this resolves the issue :smiley:

lol im still having the problem :sleepy: :pensive:

Is it showing in the task manager? If it is, end all instances of Horizon and see if it launches.

Also, if you go to C:\Program Files (x86)\Daring Development\Horizon do you see all of these files?:

image

yeah and lemme try that rn

and it doesnt come up in the task manager…

Ok. Sounds like an antivirus issue where it’s not allowing it to launch period. What AV are you running? You want to whitelist the Horizon folder from my last post in your AV.

my antivirus is off

actually wait can u send me the post?

Sure, here you go: I'm having a problem opening horizon

and yes, i do see all of them files

Ok. Lets try a clean reinstall:

  1. Uninstall via control panel and delete the Horizon folders if they still exist:
  • C:\Program Files (x86)\Daring Development\Horizon
  • C:\Users\%userprofile%\AppData\Local\Daring Development
  • C:\Users\%userprofile%\AppData\Local\Daring_Development_Inc
  1. Restart your PC then reinstall using this link: https://www.wemod.com/horizon/download

See if it launches after these steps.

1 Like

k

should i uninstall it like this?

Yep then follow the rest of the instructions in the last post.

oh okay

ok i tried it and it doesnt work

I see that you have .Net Framework 2.0, which was released in 2006. Which was 14 years ago. Not too many programs use 2.0 anymore (though some do still, so don’t uninstall it).

Is there any chance you can try installing at least version 4.0?

And I see mcaffee and malwarebytes that makes me shiver almost

Oh, I fixed it, bc I had to reset my pc bc it weren’t working properly, and now its working!

Ok glad you got it to work :+1:

Glad you managed to get the issue resolved. :slight_smile:

Enjoy!