In the last hour, all trainers have stopped working (error 10)

First off, I just found out about this program yesterday or the day before, I’m not sure. I have only used it with 2 games, and they both worked relatively well.

I was using it with Dishonored and Serious Sam 3 to moderate success (some of the cheats don’t work, but i’ll post those later)

I was last playing Serious Sam a few hours ago, using infinity trainer to get through the serious difficulty with less headache. I like it because it doesn’t disable achievements (which is a must for me)

A weird bug happened when I tried using the c4 charges, that caused me to basically flicker between locations, so i shut it down and proceeded a bit without the trainer, and saved my game.

Now, when I went to load the game back up and continue, the trainer doesn’t work. I get the error 10 message.

I tried Dishonored next, and now it too, gives me the error 10 message. Both were working fine just an hour or so ago.

I have no anti virus right now (and haven’t had it for a while)
I run it in administrator mode (although i didn’t have to do this yesterday, when it was working)
I’ve tried launching from Infinity, and launching the game from steam, and then alt-tabbing to click start on infinity
I tried uninstalling and reinstalling the game. As far as I can tell, its still the same version (2.0) and still, nothing is working now.

Its always error 10.
Very sad to see this! I hope it gets fixed, or if it does start working again, I will update the thread to say so. Thanks for your time, and the program!

update : ! I logged into Infinity app with my account and things are working again! (didn’t have to use administrator)

I will post any changes, but for now things are back to normal.

Sorry you’re having so much trouble getting Infinity to work. We just released an update that may fix the problem you’re experiencing. Infinity will auto update, but you can run the installer again to ensure you’re on the latest version. Thanks for the detailed feedback :slight_smile: Let us know how it goes.

I didn’t notice an update, but if you did, that indeed fixed it.

probably wasn’t anything I did

1 Like

We pushed about 4 updates in the past few hours addressing some pretty nasty bugs. There’s still some left that we’re dedicated to fixing ASAP.

Glad it’s working for you now!


cool, i’ve never encountered such a robust trainer program with an active community network to back it up! i’m definitely impressed. i honestly thought it was too good to be true. :heart_eyes: