Infinite Loading Games

loading problem.PNG
I’ve been using wemod since MrAntiFun joined the community and have been enjoying it, however upon updating to version 7 no games will launch, no matter which path i give it, if it is antivirus allowed and firewall exempt it just loads forever and forever, i have reinstalled 2 times, restarted the computer multiple times, deleted all wemod files and did a fresh reinstall and even moved it around from ssd to ssd, and nothing is there some bug or glitch going on? or is this just happening with me? i have tried to launch 7 different games to no avail.

Sorry to hear you are having issues. Can you provide us with the names of a few games you have tried?

1 Like

I have tried, Tropico 5, Mercenaries 2: World in Flames, Factorio, Bloons TD6, HOI4 (hearts of iron), Doom 2016 and Stellaris. on a side note i was able to make Stellaris work after reinstalling the game and wemod as well, i was thinking it was a pathing issue and that may have been it which i am trying now with other games with some success so far, i believe it may be a problem with specific games at this point.

EDIT: Ok so after a few more hours of trying i have figured out that for some reason, wemod will only work with games that are on the same drive as it which is odd (to me at least) but it has somewhat solved my problem out of the games i said i am now only having problems with Bloons TD6 which i have had problems with in the past idk if this could be called a solution but it has for the most part solved my problem.

Hmm this definitely shouldn’t be the case. @frank any ideas?

1 Like

@CalkAndBalls Does WeMod launch the game at least, or it just does nothing? The app basically just tells Steam to run the game, then waits for it to appear. To make sure Steam isn’t the issue, try pressing Win + R, run steam://launch/960090, and confirm that the game opens. That command is for Bloons TD6.

i thought so too, this time steam wasn’t the culprit since i had a similar problem a while ago.
initially when i started out trying to make it work it did launch the game but the cheats never loaded, i got it working with Bloons now but idk what i did different this time. i double checked my internet to make sure it wasn’t blocking the cheats from being download but that wasn’t the case either.

Edit: part of me thinks it has something to do with the new update but that wouldn’t explain why some games are working perfectly fine while others just don’t at all.

Can you send me an app log (after attempting to launch)? You can save it in app settings → Save Log. Thanks :slight_smile:

WIll do i’m not currently home right now, i should be soon.

1 Like

WeMod.log (32.2 KB)
This attempt was a few minutes ago with one of the games that i’ve been having problems with, it keeps saying loading but i still hear the noise of the cheat activating and then immediately deactivating.

What antivirus are you using ?
My opinion is gotta be a AV issue. Some games may work and some mite not
I know on mine after the version 7 update windows defender went crazy

1 Like

i placed wemod inside a folder where it’s exempt from the antivirus list, and same thing for firewall, i still had defender when i used version 6 and the same problem never happened. image

1 Like

@CalkAndBalls Just to confirm: in your screenshot in the original post, the Loading spinner is visible, but the hotkeys work?

This doesn’t seem like an antivirus issue.

1 Like

The loading spinner appears and stays, the game launches i can press the buttons to activate the cheat, and i hear the activation noise, however the cheats themselves do not work, only with some other games they do but the loading still keeps going even after the game has been launched.

While with other games it launched but the loading keeps going with no other response.