Inifinite Loading Screen - api.wemod.com/users:1 403 error

Hello,

I have encountered an issue where WeMod no longer loads for me. I’ve tried white-listing it in Windows Firewall and Defender. I do not have Comcast or Xfinity. I have no other antivirus installed. I’ve tried uninstalling and reinstalling, then it wouldn’t download the client and gave me a sad face. Then I got a full install file, and it’s right back to infinite loading. I looked in the console, and this is the log it generated:

app-bundle.js:1 WeMod v6.2.16
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin aurelia-templating-binding.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin aurelia-templating-binding.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin aurelia-templating-resources.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin aurelia-templating-resources.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin aurelia-event-aggregator.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin aurelia-event-aggregator.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin aurelia-history-browser.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin aurelia-history-browser.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin aurelia-templating-router.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin aurelia-templating-router.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin aurelia-dialog.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin aurelia-dialog.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin aurelia-animator-css.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin aurelia-animator-css.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin daringdev-storage-local.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin daringdev-storage-local.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin daringdev-storage-moment.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin daringdev-storage-moment.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin store/index.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin store/index.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin services/bugsnag/index.
vendor-bundle.js:46 DEBUG [aurelia] Configured plugin services/bugsnag/index.
vendor-bundle.js:46 DEBUG [aurelia] Loading plugin services/wemod/index.
api.wemod.com/users:1 Failed to load resource: the server responded with a status of 403 ()
vendor-bundle.js:60 Response
D.e. @ vendor-bundle.js:60

Any and all help is appreciated.

Hello and welcome to the WeMod community. :slight_smile:

A 403 error is triggered when a web connection is denied or forbidden.

You mentioned that WeMod is whitelisted in Window’s default virus protection. Could you try this:

  1. Disable Windows Defender entirely, temporarily of course.
  2. Then download WeMod from this direct link: https://api.wemod.com/client/download.
  3. Once re-installed, turn your AV back on then double check WeMod is added as an exception before you launch it.

If you need help disabling Windows Defender, this official Microsoft article should help: Turn off Defender antivirus protection in Windows Security - Microsoft Support.


Are you using a school/college/university internet service? We’ve had a couple of posts recently where people were unable to download WeMod because their educational institution was blocking the download. In this case you’ll likely need to use a VPN or download WeMod on a different internet connection.

Disabling Windows Defender seems to have let it run again. I already had WeMod as an exclusion, both as a process and file to be doubly sure.

After getting it to work, I turned Windows Defender back on, and restarted WeMod to see, and WeMod continues to work. I’ll keep an eye out, but it seems to be working as expected again. Thank you for your help.

Edit: It’s my private network at home. But thanks for the tip!

Glad that we’ve managed to get it working now. :slight_smile:

Antiviruses sometimes like to behave in very weird ways. It’s almost as if they’re trolling us on purpose out of boredom. :man_shrugging:

Enjoy WeMod and always feel free to post in the forum if you need help or have questions. There’s always someone who can help out. :slight_smile: