Installation Error

I faced the following problem: I get the following error when trying to install WeMod.
The error appears even with offline installation and with the antivirus turned off.
Unfortunately I cannot attach Setup Log.

Hello and welcome to the community. :slight_smile:

This error is generally caused by a security program that is on your computer or network which is interfering with the download.

This post explains how to resolve it: I can’t Install WeMod / "There was a error installing the application" - #2 by Ravenfyre.

Thanks. It seems to have worked out, despite my crooked hands.

Glad to hear that it has been resolved. :slight_smile:

Sorry that it happened. Some antivirus programs mistake WeMod for a threat and block it from downloading.
This is triggered because of how trainers work, which is by injecting code into memory addresses that games are running from in the RAM of your computer. The trainers at WeMod are completely safe and are highly encrypted, so there’s no possibility that they can be ripped nor that anything shady can be added to them.
If you’re interested in reading more about why this happens, this may help: My antivirus marked WeMod as a Trojan - #2 by Ravenfyre

Have a great day and enjoy using your games with WeMod. Always feel free to drop by the community if you have questions or need support. Or even to grab a free game from the Deals & Giveaways section of the community. :slight_smile:

I am so sorry.
I had to reinstall WeMod 5 minutes ago because my antivirus blocked changing the game process of Age of Empires II Definitive Edition, even though all WeMod files were added to the white-list.
I only installed WeMod to play this game, as others simply don’t work. Maybe You can tell me how to solve this problem. My antivirus: Dr.Web. As I understand it, the blocking occurs precisely after pressing the “Play” button in WeMod after starting the game.
The antivirus reacted to 2 files:

  1. WeModAuxiliaryService.exe (C:\Users\User1\AppData\Local\WeMod\app-7.1.18\resources\app.asar.unpacked\static\unpacked\auxiliary)
  2. TrainerLib_x64.dll (C:\Users\User1\AppData\Local\WeMod\app-7.1.18\resources\app.asar.unpacked\static\unpacked\trainerlib)

Hello! Thanks for the update.

You’ll need to add these two files as an exception in your antivirus program.

I’ve never heard of Dr.Web before, and its support documentation is quite a pain to search through for answers, but this may help:

I have added these files to antivirus exceptions, but it didn’t help. Antivirus blocks changing the game process immediately after pressing the “Play” button. I think this is the problem, but I don’t know how to fix it. I tried adding the game itself to the exceptions, but it didn’t help.
Looks like I won’t be able to play AoE 2 DE with a trainer from WeMod. I will check it works with other games.

Thank you for the update.

This antivirus seems to be excessively aggressive, just like BitDefender is (which is a nightmare and is known to block critical Windows files that the Windows operating system relies on to run smoothly, oops!).

If you haven’t already, try adding the entire WeMod folder in your Appdata folder to the antivirus’ exceptions.

If that doesn’t help, would you be interested in switching to a better known and more manageable free antivirus? Some suggestions are Avast, AVG, Kaspersky and Avira. I personally use Avast and have only had it block one trainer, which was resolved in about three minutes.
Avoid like the plague BitDefender, ESET, Nortons and Mcafee, they are ridiculously aggressive and a pain in the backside to manage.

I have been using Dr.Web for 7 years now. And I have 3 years of paid license left. This is the first time it blocks another application’s process change.
I have already added all WeMod folders to exclusions, but the antivirus blocks changing the gameplay and isolates files from the whitelist.

I checked it works with other games - WeMod works. Perhaps the antivirus reaction occurs only with AoE 2 DE.

Do you have the game on Steam or on Windows Store?

On Steam, as the special instructions state: “Go to the game main folder and rename “BattleServer” to “BattleServer backup” to disable anticheats and be able to use the trainer, Startup the game and once its fully loaded press play on the trainer.”

On Windows Store, as the special instructions state: “Startup the game and once its fully loaded press play on the trainer.”

Hope this helps.

Game purchased from Steam.
I acted strictly according to the instructions. The folder and / or file in the folder has been renamed. The game is running. Campaign launched. The trainer is started by pressing the “Play” button - the anti-virus notification about the prohibition of changing the process comes out, 2 files are blocked and the trainer stops working.
The same anti-virus response was seen on some other trainers for AoE2DE.
WeMod works with other games.