Issues with Wemod on Steam after installing Xbox Game Pass?

So I’m having a bit of an issue. I’ve been using Wemod with Baldur’s Gate 3 on Steam perfectly for the past few days since first getting my new PC.

Today I installed the Xbox Game Pass app, and suddenly the Trainer isn’t working with my BG3 on steam? It says they are loaded (with the play icon) but nothing is actually working on game.

I’ve uninstalled game pass and still the same issue. Any ideas on a fix?

Welcome to the community. :slight_smile:

Are you remembering to follow the instructions found in the trainer itself? :slight_smile:

And check the History tab, underneath the Play Button, to make sure that the most recent version of the trainer is selected in the list.

Hi so, oddly enough that’s what was causing it not to work. I’ve followed the “load and make sure you can move” since I’ve started using WeMod, however this time (after uninstalling and reinstalling didn’t work), I tried loading the mods first then loading into the game, and it worked!

I’m not sure why it suddenly switched, but I’m just happy it’s working again.

Thanks for your help!