App Horizon

My Xbox wont ask to configure my USB


#1

Can anyone help me pleeeaaaase

I’m trying to use my USB on Horizon, however, when I plug my USB in on my xbox it doesn’t ask to be configured. There’s two scenarios that keep happening to me:

1- When I format my USB on my PC in FAT32, my xbox reads it automatically without asking to configure. I’m not sure if this means it’s already configured, because Horizon still doesn’t want to read my USB.

2- When I format my USB on my PC to NTFS, my xbox gives me some options, such as format USB, but still not an option to configure. And when I format the USB on my xbox, Horizon still doesn’t want to read the USB.


#2

Format is the same as configure. If your Xbox is allowing you to move files to it it’s good to go. Try running Horizon as administrator by right clicking on the shortcut and choosing to “Run as administrator”. If that doesn’t help try a different flash drive if you have one available.


#3

Thank you for your response.

I tried another USB now, and as you said it allows me to move files to it, so step forward there.

However, it still doesn’t show on Horizon.

Could it be that my problem lies within Horizon itself? Because, I right click and run as Administrator, however, when the app opens and I try to add a device, it throws an error message saying if I don’t see my devices, I need to run Horizon as Administrator. I even tried the long way of setting it up as Administrator through Property settings, Compatibility.


#4

Do you have your profile on usb too ? Been awile since i used horizon.


#5

Like ptondo mentioned, make sure you have at least 1 game save or your profile on flash drive and try again.