NBA 2K16 Mod Not Working

The new mod for NBA 2K16 is not working correctly.
It does indeed add SP points and fans, however after playing one game with the Horizon game save the game crashes.
I tried starting a new game and the issue still persists.

Please Help :cry:


Even after it’s still not working…

If it is still crashing after creating a new game, which I assume you mean a new game save, then it isn’t Horizon causing the issue.

The game crashing only occurs after using a modded game save. I tried using multiple game saves and they all crash once modded with Horizon.
Sorry if I wasn’t clear enough…
I always keep my original un-modded game saves. The modded game saves crash, while the original game saves run fine.
To be more specific, the modded game save loads fine and it loads the modded values correctly. However as I progress in the game (specifically, complete a MyCareer basketball game) the game freezes and crashes.
The NBA 2K15 tool worked fine, I can’t get the NBA 2K16 mod to work.

The new mod for NBA 2K16 is not working correctly. please help


I think cheater is busy working on the new horizon thing (or whatever) and the whole chrome blocking horizonmb thing.

I’ll look into it thanks for reporting.

Can you mod my park rep? And make it so I never miss my shots for Xbox One

Nothing like that is possible on Xbox One yet, sorry.

A patch will be in the next update to fix this problem. Thank you for reporting it!

Still having problems with this mod after 1 game it crashes/freezes

Same here, I contacting 2k support and told them it was because of the mod, I’m gonna see if they know how to fix it!

2k support isn’t even affiliated with WeMod so contacting them makes you retarded… what do you need help with?

It’s worth a try, I spent so much freaking money on the game and I’m gonna try everything I can to get it working again.

By using horizon you violate their ToS. Not only can they choose to not help you, they can get you banned as well.

Uninstall the game, delete the titleupdates, clear cache, redownload everything, start a new profile, start a new game using the recently created profile. That should fix it.

Please upload your save file to a website like or and PM the link so I can take a look at it.

when i mod a save, from 8 mb it converts to 17 mb. i tried multiple times. Please fix i would really appreciate it :slight_smile:

Any update on mod not working? Thanks…

mine too. please help