Newer update causes corruption IMPORTANT

I made a post before but it might have been in the wrong area. I posted it a few weeks ago and got no response.

Basically, replacing files through the contents tab not only doesn’t actually replace the file, but if you repeatedly replace a file, the container becomes completely corrupted.

The files in question are Minecraft world files. Replicating is super simple. Just try to replace the savegame.dat with another file and it will say it replaced successfully, but if you extract it directly after, it was never actually replaced. Rehashing and resigning makes no change. Repeated attempts leads to corruption and a new world must be created.

As a mod tool developer, I am left with no choice but to recommend against using the latest version of Horizon for this reason. I get emails every day about this issue.

Thanks for your time. I’d be more than willing to provide more info and talk 1 on 1 about this bug. Please contact me at if you have any question . I check every email I receive :smile:

I get Xbox 360 MC worlds for my son almost daily. The most recent being yesterday, and had no issues resigning it to his profile. The only issue I’ve had is that for some reason you need Resign it twice in a row so it doesn’t show up as corrupted. I’ve been doing it that way for about a year now since it always works, why? I don’t know. I’ve recommended this to others in the recent past and for the most part it seems to work. Try it yourself and see if makes a difference.

You’re mistaking what I’m saying. I’m not talking about putting worlds onto a USB and resigning. I’m talking about replacing the savegame.dat found within the container.

You’re right, I was mistaken. But I just tried what you explained and it worked fine for me. I put one of my sons MC saves on to our flash drive, I then downloaded a hunger games map from Youtube, I then extracted the savegame.dat from the downloaded map to my desktop, I then opened my son’s save in Horizon and replaced the savegame.dat with the extracted one, and Save, Rehash & Resigned once. I just loaded it up on his 360 and it was the new downloaded map.

It could be an OS thing as well since it is happening. I know you cannot replicate it, but I’ve seen it first hand and I get dozens of emails from my customers that have the same issue. I recommend trying again, either multiple times or with differing changes in file size.

Try installing the newest version of Horizon, and installing .NET Framework 3.5 and then 4.0.

Also, have you tried this with other games? I frequently mod 360 Skyrim saves for people here via the PC version, and this involves replacing the savegame.dat. Sometimes people come back and ask for more items added, and that same savegame.dat is then replaced again with a larger file size, and the saves always work no problem.

Could there be any chance that the several 360 mod tools out there have something to do with this? Your NBT Editor/oPryzeLP Mod Tool, 360 revolution’s tool, and whatever else is out there?

Welcome to HMB, by the way. Should stick around.