Phone app unwilling to launch

So I just upgraded to pro and downloaded the phone app, only to realize it won’t launch. It just gets stuck on a black screen with the WeMod logo, and it’s been like this for 45 minutes to an hour at this point.
Did some troubleshooting on the forums, and saw suggestions of trying to use, but that only gave me a blank page, both using Safari and Chrome.
I’ve tried pretty much all suggestions I’ve been able to find on the forums; uninstall and reinstall, clearing all app data, restarting both the desktop and phone app, launching it both with and without a game running, but nothing seems to be working.
Anyone have any idea what might be causing this, or have any suggestions?

Screenshots if needed:




Welcome to the community. :slight_smile:

Sorry to hear you’re having this issue.

Is there any possibility that you have a security, antivirus or VPN app on your device which is blocking the connection to the remote services?

And try restarting your phone as well if you haven’t already, I know this sounds like an unlikely fix but in some cases restarting our tech devices does solve some issues.

It’s a standard iPhone 8 with no additional security or VPN. I also did try restarting, to no avail.
I figured it might be a wifi issue, but using mobile data didn’t work either, and any other app/webpage loads just fine using both.

Is the device jailbroken and do you know what iOS version you are on?

It’s not jailbroken, and I’m on iOS 13.3. Could that be causing issues?

That shouldn’t be an issue as iOS 12+ is supported. Can you try accessing it from a browser by going to

I’ve already tried that, only resulting in a blank page, as in the last two screenshots

Whoops sorry, I didn’t realize that was in the browser.


@AD45 Please refresh in your browser and let me know if it works now. Made a few changes :slight_smile:

It works, thank you all for your help!

1 Like

Great! The iOS app will be updated shortly with the fix too.

Edit: updated is released!