App Horizon

Played ds2 once , doesnt open again

i downloaded it from here , worked fine , i have a 2 hourr save file , doesnt work again,

it just keeps saying cant load expansion pack please try again later , same also happened to fallout

to clarify it said that the first time i played it , then i downloaded the id from here http://xboxunity.net/

THEN it worked but now it doesnt

help

To clarify, you are using Horizon? Are you using a modified console? Trying to understand your posts but can’t understand what you’re trying to accomplish.

1:yes I transferred the ids using horizon

2:yes my console is a jtag

3: problem is the game just says cant load expansion pack please try again later and I DID play the game once and had a 2hour save file on it so it just suddenly doesnt wanna open

Ps:it said that the first time I opened it then I dowbloaded the latest id then it worked

Pps: same happened to fallout 3 goty but I gave up on that

Sounds like a title update corruption issue. If the same thing is happening to several games then I’d try a different title update from xboxunity. Try going back an update or two if possible. Also, are the games legitimate retail copies or ripped?

Downloaded from https://www.google.com/url?sa=t&source=web&rct=j&url=https://googleweblight.com/i%3Fu%3Dhttps://downloadgamexbox.com/dark-souls-2-scholar-of-the-first-sin-jtag-rgh/%26grqid%3DGGzk7hp-%26s%3D1%26hl%3Den-EG%26geid%3D1084&ved=2ahUKEwjJgIT31vTmAhXkURUIHapLDiQQFjABegQIBBAH&usg=AOvVaw27kOC79lhTvm92OUEYpcWN

Also I transferred every single fallout f I’d so maybe one of them is corrupted

My guess would be that something is corrupted or wasn’t installed correctly.

Here’s a video from the site you linked that has steps to install games to a JTAG/RGH Xbox:

Since you are using ISO files, the process can get more complicated than just putting a disc in and installing. You’ve probably watched this video at least once so I’m just referencing it in case you wanted to try a game from scratch so you don’t get lost in the process.

Let me know what happens :slight_smile:

1 Like

So,I,downloaded all the ids and they didint work however I have a backup plan

Ill just download the game again , I alerady have a save file so I wont lose anything

i got the game from the recycle bin and still same error

either the problem is in the compatiblty pack or
something else

Thank you for your time but I gave up

If anybody wants to close this dissection you can