App Horizon

Please HELP!

Wemod fails to download installation files.

This one works for sure. If not you have something blocking it like antivirus

https://api.wemod.com/infinity/download

ptondo is right about something blocking the install from happening so I would recommend a clean reinstall with your AV turned off before we try anything else.

  • Uninstall through control panel, then remove this folder: C:\Users\YOURUSERHERE\AppData\Local\WeMod.

  • Disable any antivirus before reinstalling: https://www.wemod.com/download.

Having the same issue, the file that makes the installation downloads fine, but as soon as I run it, it shows a sign were it is supposed to show the download progress of the actual program, but instead it says “DOWNLOAD FAILED :(”
I had no problem installing this in my laptop like 2 weeks ago, but now I can`t do it on my desktop PC, they both have the same version of Windows 10, and all the same software like antivirus and that kind of things… The only difference is the laptop pc is not so powerful so I use the desktop one to play newer games…

Can you provide a screenshot of this happening? Something is definitely blocking the install from happening.


There you go.

I know this looks like another version of Windows, but is just a mod I use cause I like older versions better. It’s only appearence though.

BTW, I already tried disabling ALL Avast Shields before running the installer, but the result is always the same.

Have you tried using a different browser like Chrome? Nothing against Mozilla, but I’ve had people download programs and files through one browser and switching allows them to download them.

To save you some time, here’s the download link for Chrome: https://www.google.com/chrome/.

I just solved it by FIRST installing .NET Framework 4.7.1 (downloading it from another website), I guess WeMod installer is supposed to install .NET if you don’t have it already, and fails, that’s why the installer froze. After that I run again the same WeMod installer that previously failed and it worked like a charm. Hope it works for OP as well.

I guess some software I have in my laptop and not in my desktop, installed .Net on it’s own and I can’t recall.

1 Like

Usually wemod does install or ask u to install .net 4.1.7.
And I actually was gonna ask if u had it

1 Like