Problem with Infinity already.. :(

I downloaded it and installed it, try to open it and it won’t open.

Went to task manager and the process is there, but nothing pops up after like 10 minutes. Ended the process in task manager and tried running again as administrator. Same thing. :c


Hi Dustin,

Does this happen to both Horizon and Infinity, or just one of them?

I’m not sure, I don’t use my xbox anymore, I was only on HMB for the forums. So I don’t have Horizon installed on my computer.

If you like, I can try to quickly install it and see for you.

Thanks for the quick reply.

It’s probably just Infinity. I’m releasing an update in a about 10 minutes that may fix it. I’ll let you know when that happens.

I released a new build. Since you can’t run Infinity, download it from and see if it works.

1 Like

Still not working, restarted computer too…

How much memory is the process using? Does it ever go away?

It eventually goes away by itself

63,012K is the max it’s at right now.

It eventually goes away from task manager

1 Like

Well, I think it’s starting but the window isn’t popping up for some reason. What is your screen resolution? Do you have multiple monitors? Are they on/off?

Using a laptop with an external monitor. It’s set to projector only, but the backlight is still on on the laptop’s screen.

The monitor is 1920x1080

Can you see if only using the laptop screen works?

No, it doesn’t work.

Tried it and the same exact thing happened.


There are no bug reports coming in, so I don’t think an error is being thrown. I’m going to keep digging.

1 Like

Would there be any type of program that could interfere with it?

Also, what would you like me to do from here?

1 Like

Other than anti-virus, no. Try this:
Go to while Infinity is running in the background.

Wait 10 seconds. Does it say you were logged in?

EDIT: This link no longer works as of late 2016. We changed the way you log into the app.

1 Like

Signing you into Infinity

Still says signing you into infinity and the process already disappeared

I have mcafee AV Should I try to turn it off for now?

You may as well give it a shot. If that doesn’t work I’m going to package you up a custom build.

1 Like

Yeah, doesn’t work. Same thing happens, even with AV Disabled…

And just to be sure, nothing shows up in the taskbar? I’ll message you a build in 10 mins if that’s alright.

Correct, nothing shows up on the task bar.

And yes, that’s fine. Thank you

1 Like