Problems with wemod and ramdisks

so, I have been using wemod for a while now, and I love it, however I seem to have found a problem with wemod and ramdisks, or at the very least, wemod and dimmdrive (steam app for making ramdisks) and that is, when running a game on a ramdisk, even if you point wemod at the ramdisk location of the game, it flat out refuses to see the game running, even when its running, it just says it cant find it. dimmdrive works by making, I believe, system links, to the original file locations, so that steam knows no different of the game location having been moved to a ramdisk, however, that does not explain why feeding wemod the new ramdisk location is preventing it from seeing the app as running…so…figure I’ll make a post and see if this can be figured out or not. Thanks!

I will take a look at this. WeMod resolves symbolic links, so this shouldn’t be an issue.

Aside: I don’t think using a ramdisk improves performance greatly after the game has already loaded the first time. If you play the game frequently, Windows should already be storing the game files in it’s in-memory file cache.

Edit: The sound it makes when turning on is insane :rofl:

that sound it makes is even BETTER when you scare the hell outa yourself from being half awake! forgot it can be turned off, but yea…that sound…thanks for the fog horn and me now needing to change my pants windows! jokes aside, that sound is terrible, yes.

but yea, I’m not sure whats not working right, but the specific game in question I was trying to play is need for speed heat, from the origin app store, installed through steam, trying to load it with dimmdrive, not sure if its something specific with that combination or what, but it says it cant find the opened game, is specifically the issue its having, and when opening up system monitor (microsofts tech whatever site replacement for task manager, process explorer, it shows that the location is still the drive the games original install location was at, but wemod says it cant find its running process, even trying to drag it onto the custom location menu does not fix it, so I’m not sure whats going on, I tried resetting it to the original game location, and same result, but when its ACTUALLY AT that location, NOT on a ramdisk, it works just fine?)

in any case, the app seems to work without running from ramdisk, and if you need or want any extra info, lemme know and I’ll add whatever.

1 Like

A fix will be in the next app update. I’ll see if we can push it out by the end of the week. Thanks for the report!

nice! many thanks!