Punch Club Cheats not registering


I played Punch Club a couple of months ago with Infinity and all worked fine. Ran the game again today, and when i attempt to activate a cheat whilst the game is loaded, there is no sound. The cheats do not activate :frowning:

I have already tried to run Infinity as admin, and still the issue is there.

Anyone else experience this?

Hi! i just test it and works fine, even “custom time” works like a charm, try this:
Run the game via steam -> once your character is loaded -> open Infinity and click run game.
(i guess you already done that, but thats how i just did it, and worked)

1 Like

Do you have steam version?

1 Like

Also did you read the important notes?

1 Like

Which notes are you referring to?

I am running the game from Steam

In infinity, next to the start game button there might be a smaller button. Clicking that will display the important notes.

1 Like

All i can see are START GAME and END GAME (when running the actual game)

Also i can’t even toggle the cheat keys to something else


Since i was able to run it it must be something in your side,
Antivirus is disabled?
Try this options:

  1. Check cache files of steam.

    2)Use this tool: - ICDV2.bat -
  2. Unistall infinity and install again.
1 Like

Okay, either I am remembering wrong or there aren’t any important notes for that game. (I don’t use Infinity much.)

Important notes are specific instructions for using certain cheats.

There was Important Notes before. But ive not tested that after v 2.0
Could be it disappeared when we updated.

@REPPiN Could you take a look?

1 Like

Indeed important notes have been removed @MrPrecise @cooper24

anyway follow my steps:
Launch the game --> Load a savegame --> travel/spend some money/do something in game --> launch infinity --> start the trainer

Just wanted to update, i uninstalled INFINITY, reinstalled and ran the game, loaded my save file. Then i started Infinity by running as an admin. For some reason the cheats are now working!

1 Like

@cooper24 awesome :stuck_out_tongue:

I’m pretty sure it was a corrupted trainer download, also did you follow my steps?