RGH X-Box 360 Hard Drive Clone Noob Question

I was hoping someone could help me or point me in the right direction. I recently tried to upgrade the 250gb internal hard drive to a 2TB one. I formatted the drive on the 360 and proceeded to clone the drive using a 2-bay hard drive docking station. Then I plugged the new hard drive into the 360 and the 1st screen I am greeted with is one that tells me that an Xbox update is required. I click no and then it goes to the MS dashboard with no games or Aurora showing up. I go to look at the contents of the drive on the 360 and it tells me there is data on the drive, but I see nothing under the contents. I then tried reformatting it again on the 360 and used FATXplorer64 to mount both drives to my PC and simply copied all the contents from the old drive to the new. Pretty much the same result. I then plugged the old one back in and it was fine. I am not sure what I am doing wrong. Is it an incompatible drive issue (which would be weird since the 360 does see it) or did I simply not do it right? If anyone has any advice, I would appreciate it. Thank you in advance.

Have you gone about it the way instructed here: https://www.reddit.com/r/360hacks/wiki/hddupgrade

I do remember cloning an official 360 hard drive to another many years ago and it worked but it was only like a 60GB to a 250GB if I remember correctly.

Hi all,
Thank you Steve. I thought it would be harder to just do it from scratch but I watched Modded Warfare’s guide and turns out it was super simple to follow. I am good to go now and ready to take advantage of all the extra space.

Thanks again. :slight_smile:

1 Like

Years ago if it wasn’t for modded warfare my rgh would been thrown in the corner ! :grinning: