App Horizon

Rise of the Tomb Raider Cheats and Trainer for Steam


having an issue with skill points not working, everything else seems to be fine, thought maybe I needed to earn one first so I did that as well. Running 20 year celebration steam version BuildID: 2367657 Windows 10. It does activate and show as on but doesn’t affect my skillpoints.


I think you have to sit at a camp to see them change?


I tried that having the skill window open and toggling the option even spent a skill point with it enabled just to see if it would increase the number or just not consume the point but it just doesn’t seem to do anything. Also, and It may just be for bows, but the infinite ammo doesn’t seem to work for arrows where infinite resources does.


Ya xp works. And yes have to have ulimited resourses on for the arrows cuz they really aint ammo


Despite saying on the website that Rise of Tomb Raider has a trainer when in the app says one is being created?


Ya something funny is going on frank is working on it.
The trainer does work i use it all the time


Glad to know its not me. I know a few days ago it worked then I went to play yesterday and there was just nothing on the page. No listed cheats or anything. Thanks for the heads up.


And now its back today lol. Thanks guys much appreciated.


@STN every time i try to run the trainer while i’m on the game this keeps coming up - “an error has occurred while loading imports. Wrong DLL present.” i’m playing on DX11. How do i fix this?


Start the game first attach infinity afterwards


i’ve done that and it still comes up


Is it me or does Unlimited Health cause the NPC’s not to die too?


Haha. It must be you and the tomb raider games dude. Never had that happen


I have same problem here. And if I turn game first and infinity afterwards then game just freezed and nothing happen. I don’t know what is a problem here.


Soooo :smiley: Win7 64 bit version. GTX 1080Ti 11GB, 32 GB RAM, i7 6700

Where or what is problem?


Are you running dx12 version of the game


Nope :slight_smile: It’s grey. And I have Infinite in exceptions and I tried all what you told to another guys up there :slight_smile:


Your graphics card probably does not support dx12


And is it a problem? Have I download drivers for dx12? :slight_smile:


I think dx12 comes with windows 10. And the game needs dx12 to play it