Sid Meier's Pirates! Cheats and Trainer for Steam

Sid Meier's Pirates!
This is the official discussion topic of the Sid Meier's Pirates! Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Happy Crew
2. Unlimited Health Swords Fight
3. Repair Fleet Ships
4. Instant Ship Reload
5. Set Crew
6. Set Coins
7. Set Food
8. Set Luxuries
9. Set Goods
10. Set Spice
11. Set Sugar
12. Set Canon


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 11/03/2020
    Started development

  • 11/04/2020
    Released trainer with 12 cheats



Like what you see?

Check out all of the games WeMod supports here.

I tried to play this game with Wemod but It seems my computer warns me that these cheats are not safe. I believe an update is needed.

星际争霸2在那个论坛?

They are safe it’s a false positive that usually happens when you download a trainer
It is 100 % safe.
Some trainers will get through your antivirus and some get caught

Yeah, so , My antivirus found a trojan file imbeded in this trainer. Is that meant to be there?

1 Like

Hello @Rascion1981.

Your antivirus did not find a virus at all.
This is called a “false positive”. It will happen every now and again with trainers, no matter where on the internet you get them from, purely because of how they work.

The fix is simply to add WeMod as an exception in your antivirus.

  1. Please read previous posts before posting. This is explained in the post that is directly above yours.
  2. Please use the search button in the future for a faster answer. For example, this explains why it happens: Windows Defender marked WeMod as a Trojan

So I have been using the trainer for 2 days now and noticed that the crew and food work at first then quickly stopped. I might have done something wrong on my end but I thought it was best to post something here

1 Like

i downloaded the game like i do all the other games but with this one it says it cant find steam and i have steam installed

Try and start the game from steam on singleplayer first then when you are in game alt tab out then press play in wemod after click back into game

i did it both ways and nothing

WeMod, as far as I am aware, doesn’t have an error message about being unable to find the Steam launcher. That error message is likely coming from the game itself. Did you buy the game or acquire an illegally cracked version of it?

bought it through steam

When i press play it just fails and kicks me out, saying 'runtime error". I reinstalled steam, uninstalled the game and then it worked, but i used the add items thing and it failed again and i cant get it to work anymore.

The trainer doesnt seem to work for me. I try to open the game but it says:

“The cheats are missing from your computer, please make sure WeMod is allowed by your anti-virus software before continuing.”

Then i get the choice to close or fix, so i click fix and it says “auto_fix_av_failed”. And then i click OK, i try this over and over but just the same thing.

WeMod is not on my bad list so i dont understand what the problem is.

Edit: Ive reinstalled the game and WeMod aswell, same thing.