Soda Dungeon 2 Cheats and Trainer for Steam

Soda Dungeon 2
This is the official discussion topic of the Soda Dungeon 2 Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download:

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Enable Debug Menu


Important Notes:

Click here to view important information about these cheats.

Read notes before using mods.



Screenshot:



Trainer Video:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 08/24/2020
    Started development

  • 08/24/2020
    Released trainer with 1 cheat

  • 08/25/2020
    Bug fixes and game compatibility improvements



Like what you see?

Check out all of the games WeMod supports here.

The Soda Dungeon 2 cheats have been updated!

Changes:

  • Released trainer with 1 cheat



Please post in this topic if you run into any issues!

me also

same me too, the play button is constantly charging

1 Like

Me too. I am at main menu, I click “Play” button, and i just circles around.

I also tried waiting to click the “Play” button until going into the game passed the main menu. Same thing happens, just the “Play” button spinning and loading.

I also tried going into the game, then exiting back to the main menu and trying it then. It didn.t work either.

edit: also what’s up @STiNGERR thank you for all of your hard work. I’m not a pro member, so I have been enjoying your goodness for a while for free, but I plan on changing that soon. Thank you for releasing this!

1 Like

Same issue as the others, the play button keeps circling and telling me it the cheats can’t be loaded.

1 Like

Start the game first from steam then when. You are upin game alt tab out the press play button after , click back to game

yea doesnt work tried all methods

I’m locking this until we can push a fix out :blush:

The Soda Dungeon 2 cheats have been updated!

Changes:

  • Bug fixes and game compatibility improvements



Please post in this topic if you run into any issues!

3 Likes

Unlocked! Thank you @STiNGERR for the quick update!

1 Like

The trainer recognizes the game now, but I cannot see a debug menu. Everything works as intended (I think) just cannot see the debug menu.

Please make sure you follow the instructions in the cheat note.

2 Likes

I activated the cheat before pressing the version string, I’m pretty sure. I did assuming the “1.0.5” on the bottom is the thing I am supposed to click. I don’t see a debug menu at all.

Thanks for the patch, works fine :ok_hand:

Yo @STiNGERR you are the best creator man thanks for the quick fix now I have 26 trillion essence.

1 Like

Works now!

1 Like

uhhh i cant see the debug menu