Soulstice Cheats and Trainer for Epic Games

This is the official discussion topic of the Soulstice Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Invincible
3. Unlimited Jumps
4. Set Player Speed
5. Add 1K Red Orbs
6. Add 1K Blue Orbs
7. One-Hit Kills
8. Set Game Speed


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 10/14/2023
    Started development

  • 10/14/2023
    Released trainer with 8 cheats

  • 10/21/2023
    Bug fixes and game compatibility improvements

Like what you see?

Check out all of the games WeMod supports here.

The Soulstice cheats have been updated!


  • Released trainer with 8 cheats

Good trainer, does it always take that long to fully load the mods into the game? i never had that problem with other trainers do i am using the epic game version.

Greetings and keep up the good work.

they dont seem to work ??

Can you review the epic games release of soulstice? It isn’t loading into the game. The game loads when I use the exe file option but the mods don’t load into the game. Thank you :slight_smile:

Yeah it took about 18 minutes to load the mods, I’m wondering if its faster on SSD because I’m on a Hard Drive.

Nah I have an ssd and yet it’s still not loading

It needs update. After the game update the unlimited health, invincible and one-hit kill doesn’t work. The unlimited jumps and add red and blue orbs works fine.

The Soulstice cheats have been updated!


  • Bug fixes and game compatibility improvements

unable to load mods into the game, I either get the “may need allowing through or turning off firewall” pop up, tried that, didn’t work or it just hangs on “loading mods into the game”

using the epic store version

1 Like

The first time I loaded the mods it took me a little over an hour, the second time it took me half an hour.

Mod loaded after 10-15mins in to the game. All good.