STAR WARS: Squadrons Cheats and Trainer for Steam

Continuing the discussion from STAR WARS: Squadrons Cheats and Trainer for Steam:

This trainer doesnt need an update to vote for, only a fix for the F2 and F5 button. Rest works fine so please just fix option 2 and 5 so it will stay on active.
Or does nobody play it anymore?

2 Likes

The STAR WARS: Squadrons cheats have been updated!

Changes:

  • Bug fixes and game compatibility improvements



Please post in this topic if you run into any issues!

HI All
I just tried using this MOD, swapped the file, and linked to the WEMOD system of Origin version.
It will start the game but will not stay in PLAY on setting to activate any of the cheats, Possible the EXE need updating to correct this issue?
I tried to look if Origin added some checking to the game but have not found any as of yet?

As far as I know, the problem is the fact it’s for steam only. They don’t have a trainer for the Origin version of the game. Also, EA owns Origin, so there’s likely anti-cheat checking.

I just downloaded the game today. Followed the instructions above and the cheats worked without issue on Origin.
If the game updated then odds are you will want to back up the launcher again and use the one provided by MrAntiFun. Likely the update modified that file and enabled the anti cheat.

Hiya, just chiming in to say that Origin does in fact work with the Steam trainer. Follow all instructions as posted, and it’ll work without issue.

1 Like

Does it matter if the copy I got was through the EPIC store? Normally I would say YES but in this case the EPIC/STEAM store versions are really just glorified shortcuts to the ORIGIN version. So if these are indeed ‘shortcuts’ then the end result may be the same no matter what place you got it from I suppose. Has anyone tried this out to confirm?¿? (and I mean someone that knows how to navigate a pc lol)

Still works, Nov. 2021

Any chance for an unlimited Glory cheat?

Trainer doesn’t work. There is only info “We’re having trouble starting or finding your opened game.” But the game starts normaly, everything is ok with it. And yes, I’ve changed the files. It was working earlier, but after last game update, cheats doesn’t work anymore. Please update.

u can do for epic games ?

this is utterly useless, it does not work. fix it. fix it please

If you’re trying to use this trainer on the Epic Games version of the game, which is free this week - this trainer is specifically built for the Steam version, as the name suggests.

Check the development queue in the WeMod software to see if an Epic Games version is in the queue.

I noticed that the Origin version was updated about 30 minutes ago. I checked the queue for an Epic version of the mod and didn’t see one. :man_shrugging:

1 Like

would this work with the new EA app since origin was discontinued?

1 Like

How i disable anticheats? lol

I think you just have to delete or rename the “cheat”-exe and rename the exe.bak back to exe

do not use downloaded launcher for custom launch, launch game first using the launcher, set the exe to the starwarssquadrons.exe, repeat DO NOT use the launcher for the exe on wemod; it wont work

I can confirm this works for the Epic Games Version. The new launcher file stops running EAC but it is not the game file you should launch from. Do as instructed, downloading, renaming etc but make starwarssquadrons.exe the launch file for WeMod. Then open up both Epic Games and Origin to speed up loading, and then press Play in Wemod. All cheats have been confirmed as working.

Edit: Can Confirm it works for Story Mode. Just started Ace Difficulty and only Unlimited Missiles worked.

it seems it doesn’t work with the ea new app or at least don’t detect it , but maybe it’s just me the one who don’t know how to do it .

1 Like