State Of Decay [2014] Open Save Error + New DLC Support Problem

Yesterday a title update for SoD was released that I believe has currently rendered the editor on Horizon useless and or buggy. Following the release of now current title update a new DLC named State of Decay: Lifeline was also released which added some new Weapons and characters.

Current situation: I currently have been unsuccessful when trying to modify my save file and have even started with a fresh save but to no avail. Below I have included a save file that was freshly made during the new and current title update but later in the day I will post an updated save with progress from each DLC’s.

Save 1: State Of Decay (Vanilla)

Save 2: N/A

Error Code:

Open Me

Thanks for the report. I will take a look at it.

Edit: Alright, I’ve fixed the problem with loading the save. They updated the structure a bit but it works fine now, I’ll work on adding the new items and supporting the DLC game mode now.

Hey unknown did they blacklist the soldier models or something? Everytime swap one of my guys to a merc_sharpshooter , it changes to a civillian…

I believe they made it so that model is only playable via the new DLC.

Code is updated and finished. Save editor now supports “Lifeline” in the drop-down with the other game modes. Also, it seems the ammo/consumable (aspirin, etc…) cap is only for player inventories. So now the editor can do up to 255 for each ammo and consumable for lockers/home bases only though. However, the ammo in guns and hit max for weapons is still limited like in the previous update. Update will be out during this week.

Great work like usual unknown, Can’t wait for this update. Not sure if this has been brought up into conversation before but do you know if modified stats actually revert back to normal because Iv’e tried for the longest to get my players to have infinite stamina and heath but to find out that the stats get reverted back down to normal.

Lifeline doesn’t show in my drop down menu only breakdown :anguished:

Pay attention and read the whole post. Unknown clearly said that the new update for Horizon would be in effect this upcoming week. He did not specify an ETA but rest assured it’ll be available sometime in the week.

Cheers, Unknown. Very swift work! Looking forward to the update.

The update is out!

Thanks for rolling that update out much earlier than expected. :smiley:

Hey, I’m getting an unhandled exception error whenever I try to select Lifeline on the drop-down menu. The save file I’m trying to edit only has Lifeline data on it.

My save:

The error message I receive:

************** Exception Text **************
System.Exception: SoD: failed to load any game save
at A.OF.Horizon(Object E, EventArgs H)
at DevComponents.DotNetBar.ComboBoxItem.቏(Object ط, EventArgs ظ)
at System.Windows.Forms.ComboBox.OnSelectedIndexChanged(EventArgs e)
at DevComponents.DotNetBar.Controls.ComboBoxEx.OnSelectedIndexChanged(EventArgs e)
at System.Windows.Forms.ComboBox.WmReflectCommand(Message& m)
at System.Windows.Forms.ComboBox.WndProc(Message& m)
at DevComponents.DotNetBar.Controls.ComboBoxEx.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Forgot to add a check for when the save only has a Lifeline save. Fixed, thanks for the report.

It works just fine now. Thanks very much!

When ever i tried to load the state of decay mods, and i have the lifeline dlc. All that comes up is, “Data being loaded is a different size then what was saved. 00000002 != 00000080.”

Please post your save file here or send it to me. You can upload it to or

This should be the file right here. It is called “Broken Save”

Thank you, fixed it. I’d like to wait for people to report more bugs before we push out an update so people don’t have to keep updating if we get more bug reports. If you can wait a day, that would be great.

Here is a bug in the State of Decay editor , whenever I go to change a name of a character it gives me the error of a message that says ‘‘s’’ at the bottom of error message this happens when you try to save the file with that edited name other then that everything else works…Although when I try to play as Merc Sharpshooter it goes to a civillian not the merc sharpshooter. Did Undead Labs put a blacklist or a check on the merc sharpshooter?

Yea, I left that in there by accident. I’ve removed it in the next version.

I’m not sure about that, I can check to see what does that though.