Stellaris Cheats and Trainer for Steam

Sure. Is there another update planned? Don’t want to update only to have it broken the next day :smiley:

Not that I know of but there might be a beta patch, but I think the problem is because utopia screwed up alot of things even for mods

The big fish in the dev team (Martin “Wiz” Anward) said the following yesterday: “We’re now at work finalizing… bugfix/QoL update.” hence new minor update incoming , that might or might not change the game version. The next major update (1.6 “adam”) is far from now thou.

Unlimited Energy, minerals and influence does not work.
Trainer was updated 21 days ago.

Can’t open the trainer for some reason, says to check my firewall…etc, though all other trainers for other games work. Version issue?

Clear your cache with this: - ICDV2.bat - and try again.
If it does not work put the game folder as an exception in your AV

Instant Research seems to be the only feature currently working for me.

The 1.6 Adam update is out now. Instant Research is still the only feature currently operational. Maybe we could could an update to the trainer soon?

Trainer doesnt work anymore since the last Update (as skillerx13 said). An Update would be very cool guys :slight_smile:

1 Like

I got a few to work but unlimited energy, minerals, and influence wont work.

The Stellaris cheats have been updated!


  • Unlimited Food cheat added
  • Unlimited Unity cheat added

Please post in this topic if you run into any issues!

1 Like

keeps crashing the game once cheats are initialized tried a few times but same every time…also galactic civilizations 3 wont detect game for a year now but no one has updated or replied to that thread

That’s probably because of the new patch that came in yesterday.
@STN Will fix them as soon as he has time

Which cheats?

Just realized no one else has replied to this, so: all cheats. Any cheat being initialized seems to cause the game to crash.

I’m having the same problem as OracleIndex

i just tested the game and trainer is up to date. Are you using steam version?

Yeah, Does the game need to pass a few day before activating them?

No. It should work fine after loading the mission (offline).

Oh, Do you need Steam to be Offline, or do you mean the game, In which case I’ve tried with the game offline, It used to work until they added Utopia, Do you know of any mods that may clash with the trainer?