Stellaris Cheats and Trainer for Steam

The instant research speed is working, and the instant build is working. God mode and console in ironman turn on in the display, but haven’t had a chance to test them yet to see if actually working.

If you say console is working then that does indeed allow all the various materials to be created. When you get a chance to update I’m sure we’d all appreciate it. Just more convenient from the cheat display, but lower priority since there is at least another option.

Stellaris cheats seem messed up after patch :frowning:

Yup, trainer definitely needs an update after the latest patch.

The Stellaris cheats have been updated!


  • Bug fixes and game compatibility improvements
1 Like

MRANTIFUN I cant subscribe to wemod but you are the beast modding team out there ty again for this update dude much love and respect sir

The mods are still broken after the update. None of the resource adjustments work and the fast construction is broken as well.

Set influence still broken after mod update. Thanks :slight_smile:

Resources and influence working for me. Looks like everything is fixed. Thanks!

1 Like

I don’t understand what I am doing wrong, this mod is not working for me. I click set alloys (its in playing status) and nothing happens.

I am running ironman mode, the allow dev console one works so I can at least cheat that way but it would be nice if the mod just worked.

None of the options are working for me at this moment.

1 Like

resources mods are no longer working, rest seem to be


I’m totally confused right now. I was playing last night and this morning and the mod was working normally. Now, as the others report, resource options don’t seem to be working.

resource is not working, including anything that require for the amount were not working

1 Like

i found out why, there has been a small patch

1 Like

It does not work after the patch 11/23

resources not work, but speeds OK
Ctrl f6 OK
Ctrl f8 OK

Everything works for me except resource modding as well. Needs a minor update.

Well, changing the values of the UNITY and INFLUENCE still won’t work. Looking forward for any updates. Cheers

All of resource and stats are NOT WORKING.

im running into a issue with the mod recently. the cheats were working great but then one day when i tried to use the cheats to get resources i noticed that they didnt work, i was confused so i tried to use the cheats again and again and that didnt work But i noticed that the fast construction and god mode cheats still worked fine.I made a new game with a custom race and it still didnt work, i closed the game and started it again and it still didnt work.I restarted my pc to see if that would fix it and it still didnt work. I dont know why this is happening and im wondering if anyone else is experiencing this bug?