STFS Error trying to restore modded save file


I used horizon and the gibbed save editor a while back to mod my borderlands 2 saves. Long story short, my Xbox was stolen and I got it back but all the data was deleted. I still have the modded saves on my computer and I’m trying to put them back on my profile but I keep getting errors and I haven’t been able to figure out whats wrong.

The errors Im getting when dragging the files into Horizon are:

“Invalid signiture type detected for the loaded package. Halting reading. Please make sure this is a valid xbox360 Xcontent package (‘LIVE’,‘PRIS’,‘CON’)”

And If I try to inject the file it says “Invalid STFS package”

These are the same exact files I used when modding before and I’m trying to add them back to the same xbox live profile. I thought I would just have to rehash etc. What am I doing wrong? They are .sav files

Any help is greatly appreciated!

I believe what you have there are the SaveGame.sav files extracted from the contents tab of the full save container. That’s how you mod with Gibbed so it kind of makes sense. Try making a dummy save on your 360, then open it in Horizon and replace it’s SaveGame.sav file with one of your old files.
It’s here[details=Open Me][/details]

See how that works out and reply back. Good luck.

THAT WORKED!! Thank you so much!!!

I was almost positive that was your issue. If you ever need help with something don’t hesitate to start a thread or PM me about it. Glad it worked out. Have fun with your old save files!

Well shoot, now I have a new problem. You might not know the answer, but when I start up the game it keeps asking me to download the latest compatibility pack, but it doesn’t seem to register it when I download the thing. No matter how many times I download it, it still tells me to download in order to play online. Idk you may not know Borderlands 2 but I figured I’d ask just in case

Any ideas?

I was a big BL2 player, haven’t really touched it the past year though. Was it working fine before you added your old saves?

Yeah it was working fine before I added my old save but now I cant do anything online, even if I try making a new character. I tried clearing the system cache and that didn’t do anything. It was a pretty old file though, do you think I should try re adding it to my xbox with Horizon after re saving it in the newest gibbed editor?

And thank you again for your help, I really appreciate it :smiley:

Yes. Because of title updates for BL2 and updated Gibbed editors it could be screwing things up. I’m not sure what exactly is wrong but trying that is a start. See how that goes and reply back. Good luck.

Thanks so much I’ll try that and let you know what happens

Ok re saving didn’t work, but I searched the Borderlands forums and was able to figure it out. Just for reference in case anyone else has the same issue, you need to delete all of the previous compatibility packs, clear the system cache, then re download the latest compatibility pack.

Thank you so much for your help Steve Wonda, I really appreciate it!!!