App Horizon

Tom Clancy's Ghost Recon Wildlands Cheats and Trainer for Uplay


wemod provides alot of multiplayer modding, for example dying light is just 1 of many…but if you feel that way then okay :slight_smile:


@DoobieRoller420 WeMod does NOT supply or support multiplayer mods, online mods, or any other form of bastard gaming ass#### abuse. If multiplayer cheating happens, it is a byproduct of the single player mod that the maker had to choose to allow, with sadness, or remove the capability completely from the single player experience. The quickest way to get the single player feature turned off in WeMod would be to point out that a slime bucket is using it to cheat multiplayer.


What Selaena said.
Just because it works doesn’t mean it was made for it


Many thanks and much respect to @SunBeam for continuing to support this trainer (in its CE and WeMod incarnations). This trainer works fine with the Uplay version of GRW. For those having trouble, here are some notes to make it easier:

  1. In Uplay, click the hamburger (three horizontal bars) in the top left corner, then click Go offline. Never use the trainer when online.
  2. The GRW trainer supports both the Steam and Uplay launchers (the game is the same). By default Steam is selected! In WeMod, you MUST click the “Uplay” button (right below “4,739 members play this”) before clicking PLAY.
  3. There is NO need to mess with Easy Anti-Cheat command line switches or DLLs.
  4. When finished, close the game, close WeMod, then you may click the hamburger and go online to get your hard-earned prestige rewards for reaching Tier 1.
  5. The trainer may break when Ubisoft publishes a game update. Just be patient (and kind), and SunBeam will most likely publish an update pretty quickly.
  6. If you run into issues, please read the forum before posting.
1 Like

SunBeam mentioned that adding the command line switch in Steam/Origin/Uplay breaks the trainer. Are you able to confirm that? If that’s the case, the app will have to read the custom command line options set in each client to remove duplicate switches.


You must’ve misunderstood me: it doesn’t break running; it adds-up to it (as in there’s less chances it will skip the command line argument WeMod starts it with). Plus:

  1. the Steam/UPlay version having this command line set manually in both the Steam and UPlay clients bypasses completely rungame.exe. Thus no more checks on the game files integrity. The crappy errors most people complain about: no EAC; unknown file version; etc
  2. people can add it to the custom launching (exe is piped through clients, thus it will inherit the command line argument set in them).
1 Like

@frank I confirmed that adding -eac_launcher to the Uplay command line does NOT break the trainer. No need to worry about duplicate switches.

As a side note, I noticed that some games must be launched BEFORE clicking the PLAY button in WeMod, and other games are launched as a result of clicking the PLAY button. It would be helpful if game-specific instructions were provided to make this clear.


This message indicates that you added “-eac_launcher” to the Game launch arguments and are using the original 851KB EasyAntiCheat_x64.dll. I recommend removing “-eac_launcher” form the Game Launch arguments, and let the trainer handle EAC. Also, be sure you select Uplay before pressing PLAY. Steam launches differently.


I noticed that some games must be launched BEFORE clicking the PLAY button in WeMod

There should be no game that you have to do this for. What games can’t you launch from WeMod directly?


@Chris – I appreciate WeMod’s quick responsiveness to issues. I only discovered WeMod recently (thanks to a forum post by @SunBeam on FearLess Revolution). In the last few days, I’ve been downloading dozens of old Steam games and trying them with WeMod, in addition to a couple of recently acquired ones like the Shadow Warrior 2.

I had launch issues with these games (possibly others, I don’t remember):

  • Shadow Warrior 2 (GoG)
  • Dishonored (Steam)
  • Dragon Age: Origins - Ultimate Edition (Steam)

To be clear, I was able to launch these games from WeMod, but they failed to get to the “Playing” state (timeout, i think). Pressing PLAY after launching seems to work. That said, I just retested each of these and the only one that is routinely failing is Dragon Age: Origins. I may have it mis-configured, as it brings up the DAO launcher rather than starting the game. It is possible that I was seeing failures because extra first-time installer steps (i.e. installing msvcrt, DirectX, etc.) were causing startup to fail.

Sorry for cluttering the GRW Trainer thread with this post. Is it possible to move this thread elsewhere?


Hi, i don’t know exactly what I have to do to tag a ressource (and use the 10 millions thing), can you help ?


While the mod is active, walk up to one of the 4 types of supplies and it will show you a “Tag Supplies” action. Complete that action and the amount should change to 10 million in your skills menu. For me it is the “A” button on the 360 controller.

Edit: The supplies you can tag show up as green icons on the mini-map.


Hello, I have been trying to get this trainer to work for Tom Clancy Ghost Recon wild lands, and does not appear to start or operate on the game, when i try to attempt to start the trainer i get a message box and within the message is: “This game requires a special file patching to use cheats, but we were unable to patch your game. please close the game if you have it open.Otherwise you may be running a unsupported version”. However i did try the command lines that were said on recent posts, but still to no avail to get to work. My game version is the same version that’s on the wemod trainer.


Have you tried: a) moving your Steam Library out of Program Files (x86); b) disabling your AV completely (perhaps even uninstalling it to test)? There’s more to it than just command lines and “not working”. Keep Ctrl+F-ing this topic for related questions and suggested solutions. In other words “try harder”.

L.E.: Why I assumed you have the Steam version? Because you didn’t say otherwise.


my bad its the uplay version of the game


the creator said “3. If you get banned while playing online , it’s your own damn fault.”.

i dont know what is online?
I need unplug cable internet(or firewall block all ports)? Did can play in singleplayer(AI bot) and connected in servers ubisolt? too with friend/coop? can play trainer in ghost mode?



If you can’t be bothered reading I suggest you just unplug the ethernet cord.


Hello everyone !

New on WeMod then i need a bit of help (sorry), i have a steam version and my problem is when i run the trainer on “Uplay mode” (after running it on Steam mode without succes) the game is running with the “-offline” command but i get an error message saying : “We’re having trouble starting or finding your opened game”. But i properly selected the game folder (not in “program files x86”) turning off my AV etc… And after few try i get this message : “We’re having trouble loading the cheats into your game. Try restarting the game etc…” Quick edit ! Then after ton of try the trainer is running “playing” for few second and boom just “play”…
Then it’s at this moment i came for help !
Off course Uplay and Steam are offline…
Thx all

  1. Move your Steam library out of Program Files (x86) or Program Files (if you have it there). Using the root drive or another partition’s is recommended (e.g.: C:\SteamLibrary; D:\SteamLibrary).

  2. Do not pin-point to the game’s executable then using the small PLAY. WeMod is conceived in such a way that if it runs the appointed executable, it will not pass the command line arguments. Since you say you have the Steam version, WeMod should’ve detected that already; don’t see why you pointed to the executable. Click the trash-can little icon to clear that out.

  3. You can manually head into Steam/UPlay and add the command line argument to game’s properties:
    -eac_launch - this won’t interfere with WeMod’s launch and it’s even better, as it if you have it in both clients, it will bypass completely the execution rungame.exe (the EAC launcher).

Once you’ve properly done the above, return with feedback.



After a fresh Install of the game and the trainer everything is running perfectly ! Thx anyway for the fast help !!
And thanks a lot for your great job

1 Like