Total War: WARHAMMER Cheats and Trainer for Steam

Dude did you not read my post?
Especially that PART!![quote=“N1ceToMeetYou, post:344, topic:15271”]
true a new update did came out and broke the ones mentioned.

I can’t fix the trainer!
@bryan503 @bryan503 @bryan503

Huh? the update was reported just a few hours ago, i don’t just wave a magic wand and fix these cheats, TWW is nasty with its updates and i have to re-create at least one cheat from scratch after every update because its completely different and it is frustrating!

You should go and scream at game devs for still not fixing the game after almost a year, after all you paid them for a broken game and not infinity (you’re not even Pro).


So why did you first report it one hour ago?

1 Like

The Total War: WARHAMMER has been updated!


  • Fixed Skills cheats (Lord/Hero)
  • Fixed Hero movement

Please post in this topic if you run into any issues!

1 Like

error code: 9 how to fix this?

What does the error message say?
You can always try to clear your cache. Easiest way is with this: - ICDV2.bat -

ill test this one out once i move, my internet will be better so it wont take 2-3 days to install a game :slight_smile:

I keep getting a crash, every time i enter a battle after starting infinity it will CTD.

Which cheats have you activated? and what is your game version

If i activate cheats such as unlimited health or a few others, i am using the latest version of the game, i also tried unloading any mods, that did not work either.

are you playing single/offline?

Single player grand campaign.

Ok my problem is kind of weird, if i start a new game, everything i use work fine. But when i load my save, there’s a high probability for infinity to not work at all.

Edit : Ok, when i check the map, the cheat work, it’s weird, but apparently when i use the strategic map, cheats work. xD

Edit 2 : Nevermind…

Having issues getting anything to actually activate or take affect in-game.

The mods are downloaded, the game launches fine and the sounds play when I press the corresponding keys, but nothing happens.

I have tried:

  1. Reinstalling Infinity and using the tool to clear it and reset it.

  2. Restarting Steam/Warhammer multiple times

  3. Restarting PC.

  4. Disabling mods for the game and seeing if that affects it in any way. No dice.

  5. Read somewhere that the network driver for Hamachi was interfering, so I uninstalled that and Evolve which works in the same fashion. Nada.

My game is a legitimate steam copy and I have had it working before - not sure what’s changed. I am running Win 10 32 Bit.

Any help would be appreciated,


Read trainer notes. Also are you using infinity v3 or v2?

Where can I see the trainer notes?

I am using v2. I actually got it working last night - all except for the ‘Fast Recruiting’ option were working. It began working after reinstalling Infinity - restarting my PC and starting a fresh, new game but it stopped working when I tried again this morning.

For testing, I downloaded and installed v3 and tried for a while to get that to work and nothing took effect.


Can someone tell me exactly how the fast recruiting cheat is meant to work? Like how to activate it.

you activate it and then you recruit

Oh thanks. I figured it had to be that just hadn’t gotten around to clearing out the massive recruit que to test it. So hate waiting 24 turns for a damn poleman because I’m updating four army’s then magically the ai sends three or four army’s into my lands.