Trouble downloading Infinity Setup to My PC. Install Interuptions and AV Issues As Well

Downloading AND installing Infinity has been near impossible for me. So far I am nowhere. Downloading through Microsoft Edge gives me a file location error, Internet Explorer downloads half-way, then gives me a disruption error, and Google Chrome can’t download the file straight up because of a permission issue (?). So after all of this, checking my files each time, I then went to disable my Windows Firewall Defender (private network) and turn off my Webroot SecureAnywhere AV & Realtime Shield services, even optimized my PC’s cache, and THEN went back to try again. This time it downloads through Microsoft Edge (so it was my Webroot because Defender Firewall’s notification popped up unalarmed anyhow, simply warning me that I was downloading with it turned off), but now some WEIRD stuff is happening…

So I download it and attempt to run it right away and it gives me an error window headed with “C:\Users*MyNameAnonymous*\Downloads\Infinity-Setup.exe” and the message reads “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.” I looked for it in my File Explorer. It wasn’t there. So I sweeped my files out again and made another download, then exited, opened up File Explorer, and there it was. I ran it as administrator, as I saw in some support pages here, but it did the same as it would have if I ran it normally- it crashed immediately and the application disappeared. So something deleted it I’m guessing? I went through this whole process 5 friggin’ times with Task Manager open and nothing conspicuous of my AV pops up, every other time, I had AV on, then off. Disk and CPU space jumps with the Av, so AV deleted it. I turned it off, nothing happened in task manager. Infinity Setup still did the same flash appearance and did its magic disappearing app trick again.

HALP ME

Sounds like a cluster-■■■■ of protection softwares causing more issue than most malwares would. Maybe go minimalistic (no real time protection and regular firewall)?

Common sense and malwarebytes free (occasional scans for piece of mind) should be enough.

You could try downloading the full installer (https://api.wemod.com/infinity/download) on another system and moving it the the pc causing issues, though it sounds like there will be more problems just waiting to happen.

Well not sure cuz i have well i had webroot (paid one ) and had no problems with infinity or trainers. It ran out so dont have no more. You have windows 10 april 5 2017 update ?

  • Literally just yesterday, a major software update had notified me, so that night I did the software update. They usually do come late though because my region’s network is a bit isolated (caribbean, where internet is not at its finest), so I can’t be sure which date this update is matched to…
  • Honestly, I’m not sure what you’re talking about :joy: but I’m gonna go look up what that means and see how practical that would be for my PC, as it’s a stock Lenovo gaming laptop that’s been modified heavily. If it involves switching drives or importing, then I’m already half-convinced that it’s not possible

Okay so I used your link and it downloaded with all AV and firewall programs on xD that was stupidly easy.

And Holy S*** in Jesus’s Toilet, it worked! Infinity is running

Edit This link worked on my PC as is, with all defenses running (weird). May I ask the difference between the download file on the Infinity page and the one you provided here? I’m curious.
Otherwise, this issue has been solved - thank you!

The one I linked comes with everything in it while the normal installer downloads most of the required files while installing.