App Horizon

Unable to download single trainer, everything else works fine

I am so confused about this I just dont even know anymore. So I decided to play some Dead Cells today which has been fun but decided I wanted to have some extra gold.

I tried downloading the trainer through WeMod app and it failed with the error “We are having trouble downloading the cheats. Please try again later” with options to click Ok and Help (The page Help leads to is broken by the way)

I also got a prompt from my AV saying it blocked a file from downloading, which I thought was pretty odd as I have been downloading new trainers for other games pretty routinely, latest one being yesterday. Double checked and verified I had both the appdata\local\wemod & appdata\roaming\wemod folders whitelisted in my AV for live protection and for scans. Disabled my AV all together and tried again.

Same issue.

Went and tried downloading a different trainer through WeMod and it worked 100% no issue… Strange, but I figured maybe when my AV stopped it the first time it corrupted some of the files and they are stuck in limbo. So I went ahead and uninstalled WeMod, deleted both appdata folders altogether, downloaded the setup fresh from the website, reinstalled, and tried again.

Same issue.

Verified I could still download other trainers still successfully. Went into the settings and changed to beta release, waited for the prompt to restart for an update, restarted and tried again.

Same issue…

I don’t know where to go from here. AV is completely disabled, windows firewall is off as my AV is also a firewall(disabled with the AV). Can download any other trainer through WeMod app except Dead Cells.

What AV are you using? Some aren’t truly disabled unless you completely close them from tasks manager.