"Update needed to use any Diamond Tools"

I downloaded Horizon and I keep getting an error message when I open it, telling me that there is an update of Horizon and i must download it to use the Diamond tools and I was going to buy Diamond, but not if I can’t even use them. Please help. Thanks,
aaay44

This download link should work: https://www.horizonmb.com/client/v2/latest.php

Thanks, it actually worked :smile:

Glad it did. And nice Diamond you got there! Enjoy modding. :smile:
Closed.