USB Not Being Recognized Horizon

Hey everyone, I just started getting this problem today and can’t figure it out. So I’m trying to move my profile from my usb to my desktop but for some reason my usb is not being recognized in Horizon. Here’s what I have done:

  1. Formatted my usb to the Xbox 360
  2. Moved profile over to formatted USB
  3. Ran Horizon as administrator

Once I do all this nothing shows up in the device manager for Horizon, when I look at the my pc section it shows my usb plugged in and allows me to enter the usb but all that’s in there is a text document named “name”. This leads me to believe that my Xbox is not formatting the USB correctly. I have tried this with multiple USB’s but none of them work and lead to the same issue. I have tried reformatting the USB to the computer then formatting it back the my console as well and that has not worked. On my console it also shows my USB and I can move files and saves to it and it has the Xbox files added after I format it so I’m really not sure what’s going on here and what to do, I have tried looking for an answer online but can not find anything that will help me.