USB not recognized

hi . I’ve been using horizon for a couple years and I was working flawlessly on dashboard 16202 and windows 7 ultimate
now I flashed mt xbox to lt3.0 , updated to dashboard 17502 and updated to windows 10 pro .
I wanted to insert a demo to my usb but it’s not recognized in horizon nor the PC itself .
I tried running as admin , reformatting the flash drive but it not showing up …
it also doesn’t work with modio , usbxtaf , fatxplorer nor party buffalo
any help ?

Have you tried formatting it on your 360 since updating the dash?

Try reformatting the USB, as Stevie Wonder said

1 Like

i have this same problem and yes i have ran it as admin and i have formatted it on my pc and on my xbox 360 but it still doesnt show up in horizon

Made me giggle

yes i did … but it still doesnt work

I would say that make sure you’re running the most current version of Horizon and have it running as administrator, but if it’s other tools not working either then something might be wrong with the USB. And that’s as far as my technical abilities go.