USB problem

I’m formatting on pc (fat32) then when i plug it in to the xbox it says USB Storage Device 983 mb free
And it says the same thing in my computer…

This usb worked for me before but now it isnt, i press Y on it and it gives me
clear system cache
transfer content

I’ve done them all and nothings working for me I’v been googlin for abour an hour or so and couldnt find anything to relate to my problem

its total storage is 988mb

EDIT: Everything ive been putting into my xbox only reads it the same way, rename format clear cache and transfer content

So is it not showing up on Horizon?

yea, but I figured out whats going on…
its already configured its just not showing up on horizon. Here’s a list on things I did to try to get it to work agian.

1: Open as admin…CHECK
2:Formatted (fat 32), plugged it in Xbox; Format. Move save file to FD(flash drive). Plug into comp.{Doesn’t say device is connected}CHECK
3:Reinstalled HORIZON for the older version. Re-tried steps 1. and 2.

So basically the only problem is…

  1. An update problem or something to do with software.
  2. The FD has worked before. The problem can’t be the FD. (But sometimes that really IS the problem, but I think its fine.)

Thanks for your time and help.

  1. Have you tried this link?

  2. Do the flash drive work when you plug it into your xbox?

I updated it thru the program and the flash drive works on both pc and xbox its just horizon doesn’t read it