USB showing "No Content"

i have xbox 360 slim with rgh and when i open the usb hard drive to computer the horizon show me nothing

Is it formatted to your xbox?

yes and i try to re install horizon

Have you moved anything from your xbox over to your memory unit?

Some USB’s just aren’t compatible with Horizon for some reason. I’ve had this happen to me before and I needed to use a new flash drive. If you can transfer that data back to your 360 then use another USB, format, move the stuff back to that, then open Horizon with it plugged in, you should have your data.

Just curious, what all did you have on it?

its happen to me after i install COD AW but i didn’t move anything and its works before

-snip

you mean i have to uninstall COD AW form my xbox ?

Have you tried running Horizon as an administrator?

yes sure

You may have tried this, but if not, try plugging your flash drive into another USB port, sometimes this may be the cause, not always, but sometimes. If this doesn’t seem to work, post back…

Hmm… its still dosent work i allso try in another computer and still dosent work