USB Troubles

How to connect a USB

Have you configured xbox storage on the unit?

i am having the same problem for some reason i am not able to view the files on the program. i reformatted the usb stick twice and move the files over not copied them and i am still haveing the same damn problem i don’t know what else to do?

Okay this is what I have concluded to. I use the same USB i used MONTHS ago and it stopped working FOR HORIZON It works on my computer and I even tried it on Modio. It seemed to work but I try on horizon it doesn’t and I don’t even have the latest version unless it auto updates. So I downloaded the newest one on my brothers computer and it STILL didn’t work. So its most likely the program BUT if people can still get on it its the computer. when I plug in the usb it show it loading but doesn’t go all the way and just stops. But on my computer it says “Removable Disk Drive”. So really i’m POSITIVE it’s horison

We need more information to try and figure out your problem:

Can you take a screenshot or describe the contents of the root directory of your USB file? Like what files do you see when you open it, if you do not see anything, try settings your computer to show hidden files (example for Windows 8: , if you have another operating system, you can google how for that one.)

my usb still will not come up i have plugged it in and nothing