"We’re having trouble downloading the cheats. Please try again later" message for only 1 game

I keep getting the error message “We’re having trouble downloading the cheats. Please try again later”, for Persona 4 Golden. Every other game works except for this one. The trainer was working two days ago, I don’t know what happen?

I already tried uninstalling and reinstalling, but no dice. I also don’t have any anti-virus program that will be blocking it, and window firewall already has an exception. Any help guys?

Try and start the game first from were you bought it from then when you are in game alt tab out press play in wemod after game is running. Sometimes that works

No luck, same problem. I tried Lego Star Wars, Dishonored, and Hollow Knight, all worked. Weird how Persona 4 is the only one not working

Looks like the trainer mite be in need of an update.

So its not a fault on my end correct? Just checking.

No, that message has nothing to do with an update to the game. That means WeMod is unable to download the trainer. Generally, it is caused by an antivirus or firewall.