We`re having trouble downloading the Cheats. Please try again later

Hello everybody
I have a problem with my Wemod app.
I have the problem with a few games that I cannot use the trainer, which means that whoever I want to start the trainer comes a popup and it says: We`re having trouble downloading the Cheats. Please try again later.
I have already added the Weemod app to my virus scanner

Most trainers you can start the game from the store you bought it from then when in game can alt tab out then press the play button in wemod after

1 Like

In addition to the above, make sure your games are legitimately purchased.

The main reasons for this error are:

  • Interference from antivirus programs.
  • The game or trainer are in need of an update.
  • The copy of the game you have is cracked or pirated.
  • You’re using the wrong trainer (ie: Using a Steam trainer on a Windows Store game or a Uplay trainer on a Uplay+ game).

If you’re still having the issue after @ptondo’s advice above:

  • Which game(s) are you having the issue with?
  • Which trainer(s) are you trying to use?
  • Where did you get the game(s) from?
1 Like
  • I added WeMod as an exception to the antivirus program, and even switched it off it still doesn’t work.
  • The game and the trainer are updated.
  • they are all original games from either Steam or Uplay
  • I also use the right trainer

-I wanted to use WeMod for Scrab Mechanics and Borderlands2

  • at Scrab mechanics I wanted to use Stingerr’s trainer and at Bordelands2 I wanted to use MrAntiFun’s
  • I bought all my games either on Steam, at Uplay or at MMOGA.de.

and nothing worked it always comes the same error message: We’re having trouble downloading the Cheats. Please try again later.

THX 4 Help

Those 2 trainers are working perfectly fine you must still have something blocking the trainers from working. We’re having trouble downloading cheats is usually always an AV issue

1 Like

As @ptondo said, something is likely blocking the trainers from injecting, like an antivirus program, college firewall, etc.

See and follow the steps in this post here for further help: Wemod failed loading the cheats into your game. :slight_smile:

1 Like