Wemod doesn't work on games in a windows shared folder

I have a file server that has a “steam” share, that is added to all my computers. If a game is on the share in steam it plays fine, but wemod will never see it, even if i add the .exe manually.

Specifically i have \192.168.1.12\steam\ mounted as drive letter S:\ on windows. In steam i just tell it that i have a steam library on drive S:, and it sees all of my games there.

this may be a “suggestion” or it may be a pro feature, i am not sure.

Did you try to start the game and when the game is launched, then press play in WeMod?
But if the game isn‘t running on your PC it can’t work.

yes, it won’t see the running game if it’s launched from the share. If i copy the same game to local drive and restart steam, wemod works with that game.

Then you aren‘t able to use WeMod with your server. Due to technical aspects it isn‘t possible to find the gamefiles.

Are the files on a NAS, or are you running the game on a completely separate computer and just streaming it back to yours?

me too

1 Like

Could you please describe, what exactly is your problem?

Yes, on a NAS. It’s a synology, and it exports NFS and CIFS/SMB shares, which i have mounted as drive letters on windows, S: is the steam share.

To reiterate my problem again, if a game is stored on the NAS / shared folder, wemod won’t see it, even if i launch the game first and then hit “play” in wemod. If i copy the same game from the NAS to my local steam folder, wemod can both launch the game with mods and start mods after the game has started.

Wemod can’t find a running game if the game is stored on a file share, CIFS filesystem, SMB filesystem, NAS, mounted folder. whatever you want to call it. Wemod, if the game is not stored on my local drive (local to wemod), will not work, it just says “retry” because it can’t find the game executable running.

If the game is not locally stored, wemod, upon hitting “play” will launch the game, but will never actually load the mods.

I’m not sure why it would matter if the game is on NAS if you click play after it has been loaded. I’ll check with Frank and make sure there isn’t something I’m missing, but as far as I know, WeMod just looks for a process with a name matching the exe.

1 Like

I just tried again with clicker heroes, which is free on steam and relatively small. It’s installed to the NAS share, if i click play in wemod, it launches clicker heroes, then says:
image

i click “Retry” and it changes focus back to Clicker Heroes, and a few moments later it shows the same error. So i click “OK” and hit “Play” again, focus goes to clicker heroes again, few moments, same error pops again.

I go into steam, right click Clicker Heroes, properties, move install folder to my local drive C: - Click play in WeMod, clicker heroes launches, WeMod says “Playing”.

it doesn’t matter what game i try. Clicker Heroes is just tiny (70MB) and free, so if anyone else wants to test, it should suffice.

I’m going to go out on a limb here and say that it’s probably something in the code that doesn’t like filenames like “\192.168.1.12\steam\steamapps\common\somegame\bin\somegame.exe”
image

notice the double backslash in the Location. If i go into steam and right click Clicker Heroes, pick manage, pick “browse local files”, it shows the “drive” as “S:”

This would be my guess as to the underlying issue. Anyhow, a suggestion. apologies if i made too many posts about this!

I checked with a developer, and he is pretty sure it does not work due to the way NAS devices work on windows. While the drive is mounted and shows the drive as a local drive, the actual path may differ. Without digging into it more, it is just a guess.

I made a change to the backend that should confirm if this is the issue. Can you try Clicker Heroes again?

Clicker heroes launched from NAS via WeMod worked, and the “mega money” cheat (edit: all cheats) worked as well.

Not sure what happened, here!

I triple checked it was actually coming via \192.168.1.12\ as well, so whatever change was made, at least clicker heroes works!

:smiley: