Wemod infinite loading screen

I have looked up several topics with a similar issue but none of those work for me.
I don’t use xfinity, tried restart/reinstall wemod, and tried clearing the AppData. But the infinite loading screen problem still exists.
I currently live in China and using VPN can’t solve the issue.
Is there anything else I should do?

Welcome to the community. :slight_smile:

First of all, thank you for being Pro, it helps with the costs of trainer development and software maintenance. We appreciate it. :slight_smile:

Sorry to hear that you’re having this issue. Could you try this, please?

  1. Launch Task Manager (keyboard shortcut: Ctrl+Shift+Esc).
  2. At the bottom of the Task Manager window, click “More Details” if you haven’t done so already.
  3. Scroll down to Background Processes. Look for all instances of WeMod.
  4. Right-Click all WeMod processes one at a time and select “End Task”.
  5. Once all WeMod processes in Task Manager have been ended, try re-launching WeMod.

If this does not help then there is likely an antivirus program or a firewall blocking WeMod from operating correctly. Follow the troubleshooting in this post to prevent your antivirus program from interfering with WeMod: Can’t Install WeMod.

There’s also a possibility that the “Great Firewall of China” is contributing to your issues. A VPN may help here since the firewall itself is beyond your control.

Keep us updated. :slight_smile:

1 Like