WeMod "Loading mods" frozen (Medieval Dinasty)


I am having an issue with WeMod recently.
After I enter Medieval Dinasty and enter my save file, I load WeMod.
And I have to wait for at least 1h for the WeMod cheat interface to kick in.
If I close WeMod now and reload it, I will receive this error:

I have been using it for the past year without any software change of any kind and it has worked perfectly every time. But in the last 2 weeks, I haven’t been able to use it…
I have tried:

  • Uninstall, reinstall
  • Full uninstall, reinstall
  • Turned off Firewall
  • Added permissions
  • Deactivated antivirus
  • Added permissions to antivirus.
    It is always running with administrator permissions.

Is there anything you can do to help me?

Thank you.
Kind regards,


Are you playing the beta version again, which seemed to be the cause of your issue the last time you reported this trainer having issues? :slight_smile: (Link).

Trainers are only built to work on vanilla public versions, not beta versions. Because beta versions update far too frequently for a trainer to be economical.

Hi, no, of course not :slight_smile:

Hi, coming back with an update
I also fully uninstalled all versions of the game (beta, beta staging and original) and it’s having the same issue.

Hello and thank you for the update. :slight_smile:

  1. Make sure your game is legitimately purchased from the store. Trainers are generally incompatible with cracked games, and WeMod won’t deliberately make its trainers compatible with them as a law-respecting business.

  2. In the top-right of the trainer, underneath the Play button, is another button that says “History”. Click this and make sure the most recent trainer is selected.

  3. Disable any other mods you have on the game (ie, from nexus Mods) and try again. They may be trying to edit the same RAM memory address that the trainer needs to inject into.

  4. Try the following:

    • Open WeMod. Do not press Play.
    • Open Steam (or whichever launcher you use). Launch the game from there.
    • Wait on the main menu for 5 minutes. Go and make a cup of tea while you wait.
    • Press Alt + Tab on your keyboard to switch to WeMod. Press Play.
    • Alt + Tab back to the game.

Unrelated note (click here)

Seeing as you like medieval games. Kingdom Come: Deliverance might be of interest to you. But be warned it is a tad difficult and the combat mechanics take a lot of getting used to.
Here’s the Steam page: Kingdom Come: Deliverance on Steam. But you can get it currently for 84% off via CDKeys: Kingdom Come: Deliverance | PC | CDKeys.

Have an epic weekend! :smiley: