App Horizon

WeMod not working)

So. I am user of 2014 and never had any big problem only minor i can fix. I am writing, cause i tried everything i could to get it working. Problem is, WeMod not detecting any games i have installed on Steam and other places - when i choose manually it just not working.
I played yesterday, and everyting worked as always - now i turned game and wemod and PLAY button just loading.
I tried:

  1. Restart PC
  2. Reinstall WeMod
  3. Tried with other games and no result
  4. Log in/out
  5. CTRL+SHIFT+D gives me a lot of errors.

I think maybe its beacuse of Steam Update or something. But can some assist me? I am not in hurry at all btw :slight_smile:

+1.

Don’t know what happened, WeMod won’t latch on to any of the games. The “Play” button is stuck permanently loading. Even with a Custom Installation WeMod won’t latch on to anything.

2 Likes

Ok. So that means, i’m not the only person having this issue. Thx for reply

2 Likes

@NESIIRO & @Thranduil1337.

Please go to the settings in your WeMod desktop app (the down arrow in the top-right).
Then look on the left and make sure you have the latest version of the software, which is at the time of this post:

3

If your software is up to date, try switching to the Beta Channel (in the same place you found the version above). Then close WeMod completely (including via Task Manager), re-launch it and see if anything changes.


If you’re still having an issue, try completely removing WeMod from your computer.
Turn off your anti-virus temporarily and then re-install it from this link: https://api.wemod.com/client/download.
Then add the software as an exception in your anti-virus before launching it.

1 Like

Ok i tried everything. I renstalled and got 6.2.15 and still nothing. I changed the channel too Beta and re-opened WeMod. Nothing. I can’t find install location so i can’t don nothing with antivirus. I never had any problems, and i use Malwarebytes and of course WD.

1 Like

Nothing to do. WeMod have some issues right now. All of my Steam games do not exist via WeMod.

1 Like

Quoted from another thread:

1 Like

WOW Thank You! This link you send me was the solution. I tried every step you told me, but the link helped me. Thank You again. I owe you a cookie :smiley:

1 Like

I’m glad that WeMod works for you now. Have fun! :slight_smile:

(Ps - Make it a chocolate cookie, please :yum: ).

1 Like

WeMod doesn’t work anymore fpr me. The start screen hangs. Reinstallation didn’t help. All files are whitelisted in my antivirus and firewall…
It’s also not possible to download WeMod with the “WeMod-Setup.exe” because the message “failed to download :-(” appears. I tried to install it with the client “WeMod-6.2.15.exe” from here: https://api.wemod.com/client/download which was working but the start screen still hangs and WeMod does not start… any ideas?

@severius
Do you have Comcast/xfinity? You’ll need to disable the advanced security feature because it likes to block legit stuff.

It does sound like something is being blocked from being downloaded.

I’d suggest re-installing again from this link, but with your anti-virus turned off completely.
And then before you launch WeMod, add the files from this post above as exceptions in the antivirus.

I did what you said. I also whitelisted the files in the Windows-Firewall… Unfortunately it still doesn’t work. I’m from germany, can this be the reason?

I tried whitelisting the files in Windows-Firewall and it didn’t work. I have also uninstalled and reinstalled the app. Would my university’s wifi have anything to do with it?

Yes it would. Probably need to use a VPN for wemod

Sorry to necro a thread, but I am having this same issue now. I have tried all the above suggestions as well. Some of my games work just fine and now some of them just hang up on play. I have tried custom installation paths too. And I have enabled a VPN just in case that worked. Was there ever a sure fix fix or patch for this?

Also, does anybody know of a way to download trainers off of WeMod for offline use in case something like this happens?

Welcome to the community @TheMageBlood. :slight_smile:

  • Have you checked if the games you’re trying to use WeMod on need to have their trainer updated due to a game update?
  • Are you using the correct trainer for the store that you bought the game from (ie, using a Steam trainer on a Steam game, as opposed to using a Steam trainer on a Uplay game)? Note that cracked games will have compatibility issues with trainers and there is no fix for this.

Try out the troubleshooting in this post here: Wemod failed loading the cheats into your game.

Once you have used the trainer once then it is on your PC ready to be used the next time you launch the game, including while your PC is offline. :slight_smile:

The trainer I am using is up to date with the game. And I have tried every instance of the versions (Steam, GOG, Origin, etc.) just in case. This is a new issue. And none of them (my installed games) seem to work correctly anymore. I’ve even downloaded a fresh install in case it was a server error.

As for the offline question: good to know, thank you! Any way I can get it to launch while using something like Vortex? (I.e. nexus mods, for graphic enhancements and the like, that need to be run through that program)

Also, thank you for the kind welcome!

Did you upgrade to “pro”?

You can alt tab out then press play in wemod after the game is running.

I have not updated to Pro. As far as I can tell, I have done nothing different, save updating WeMod with the most recent versions.

Wow… Now I feel like an idiot haha
That worked on one of the games running through vortex. Thanks a million for that!

1 Like