Wemod stuck on infinite loading screen

Wemod will not start any steam game. After pressing play it says its loading but never does. Ive tried starting games first with same results.

I tried all the trouble shooting and fixes i could find on previous reports of same issue with no results.
Including: .frame work update and fix, security & firewall allowance and turned off both, uninstalled/reinstalled wemod several times. Also while deleting the root files.

Is there anything eles to try?

1 Like

I have the same issue with red alert 3.

I’ve just spent around 5k (£) on a brand new gaming laptop which is able to start and run this game without any hassle yet any games that are now begun, do not load at all. Leaves me on the desktop with no further information.

Maybe I’ve been banned because of the mods i play (offline) with?

Dunno, I’m just your typical moron :laughing:

Hello support, any update, info, fix?


Have you tried adding these WeMod folders to your antivirus’ exception list?


Not those folders, only the wemod.exe. Don’t think they showed up in the list of allowances to be allowed. Will try this afternoon.

This didn’t change anything. I even tried turning off my firewall and security services still didn’t work. I also uninstalled wemod deleted folders and reinstalled with security services and firewall off. No changes.

Update please

Update please, on fix.

Where is the support for this issue?? been going on for nearly a month now? I’m going to give it a couple of days and I’m going to move to a different platform.

Unfortunately, it appears that the root cause of this problem lies on the user’s end, and despite our best efforts, we have been unable to replicate it. To date, the only viable solutions that users have shared involve either a complete uninstallation of their antivirus software or a fresh reinstallation of the Windows operating system.