WeMod won't open and stuck on Checking for Updates

I am experiencing an issue where it’ll stuck on saying checking for updates I tried uninstalling then reinstalling wemod, It still doing the same thing and I don’t know why it won’t load.

Same, just happened today. tried to restart didn’t work. tried ending task on task manager then start again nothing.

1 Like

Same for me.

1 Like

I’m having the same issue.

1 Like

Mine seems to be working now.

Now I’m one step further.
The app was loaded, now it hangs when loading the mods.
Maybe it’s just a matter of time before things run smoothly again.

I thought the same thing, eventually got passed the update screen but not all my games are loading even though they are supposed to be “cached” and work offline because thats all I am getting at the moment even with no network interuptions

1 Like

Same. I thought it was working.

1 Like

I think I found a work-around.
Navigate to : C:\Users<username>\AppData\Local\WeMod

You will see folders : such as : app-8.6.0
app-8.9.0 (app-8.9.0 is the latest version)

If you go inside the folder and run wemod.exe - it will skip the update step - but it still takes a while to do the loading.

Ate the bullet and closed mine, update was checking in 2 seconds and everythings back, Hopefully they have fixed the issue and we wont see it again for a while

Are you still experiencing this issue?

Got the same problem today. any fix yet?

Same here after today’s update

I think the server is offline. I uninstalled Wemod and cleared everything. Now I’m trying to manually download the installer, and the “Download” button on the website just keeps processing until it timed out with message “Web server is returning an unknown error Error code 520”

any way to block update check ?

Yeah seems the WeMod api server is down atm :confused:

How do we get it back up? Who do we call?

found a temporary work-around

go to C:\Users\ [USER] \AppData\Local\WeMod
rename update.exe => Update.exe.bak for example

Wemod can’t update and start

you can also do like @Baaleos wrote a week ago (not tried)

guess its down?

I think its down. The download button doesnt even work. The work around i got is to start wemod offline. While its limited use can still play your recent games.