WeMod won't work for any game I have. Tried everything

I got WeMod to work back at the beginning of September in No Man’s Sky after the updated trainer for Frontiers expansion. Even back then I accidentally managed to make it work. I reinstalled wemod, the games, turned off my antivirus, put exceptions for WeMod on my antivirus, but no luck. I tried every compatible game I have on my pc and nothing. I have launched the game and waited for 5 minutes and then alt tabbing to WeMod to press play but every time it won’t work. I checked the log and the problem is it fails to inject. I don’t know what to do I’ve tried everything from the forums to no avail.

Latest game I tried was Deep Rock Galactic. I will leave the log file here in case someone can help.
WeMod-1633096016524.log (18.4 KB)


So we can better look at the trainers, which stores did you purchase these games from? Or are they cracked pirated?

Your log states this: DEBUG [native] InjectDll:245 failed. - Which generally means the trainer’s attempt to inject its code into your PC’s RAM was blocked by a security program on the machine or network.

  • Check the quarantine menu or virus chest in your antivirus program (Bullguard Antivirus - not one I am personally aware of). If a WeMod file is quarantined there, then remove it and add it as an exception.
    Some excessively aggressive antiviruses like to quarantine things that were added as an exception. Such as BitDefender. I’m not personally familiar with Bullguard and whether it falls into the category of excessively aggressive programs.

  • Are you using your own home WiFi network? Or one that belongs to an insitution such as a school or college? And are you from a Chinese territory?

  • Are you using a VPN? If so, turn it off and try again. It may be affecting the trainer’s download. WeMod needs unrestricted access to the internet to download trainers for the first time it is used. Then WeMod can be used offline once the trainer is downloaded completely onto your machine.

I am using my own Internet connection. I am not form a Chinese territory. I am not using VPN. I turned Bullguard Antivirus off and used Windows Defender instead but still got the same issue. I went through all the processes again and managed to put all the failed ones on white list and it worked. Than k you so much for the quick response btw. Customer support gets a ++ from me!!

Thank you for the update, I’m glad to hear the issues has been resolved now. :slight_smile:

Enjoy using WeMod and always feel free to pop into the community when you need, or even just to grab the occasional free games from the Deals & Giveaways section.