App Horizon

Won't download

Hello,
When I download the exe and run it. It starts for about a minute maybe less then says. I’ve tried deleting reinstalling about 10 times now. I am out of ideas. It was working fine then it wasn’t so I uninstalled it to reinstall it. Now this is popping up.
:frowning:
Please Wait while the required files are downloaded.![Screenshot

(1)|690x388](upload://3ZiDNYEgzRw9clyqqQyc3OBmXNH.jpeg)

1 Like

Try this one and see what happens
Make sure to end all in task manager if there is any
https://api.wemod.com/client/download
Or could be an antivirus issue too.

Hi, the link won’t even load. I turned off anti virus real time scanning. It still just does the same thing.

What is your antivirus. Turning off real time scanning almost does nothing. Mite have to whitelist the wemod exe’s


It’s the same for all AV’s

I have Mcafee, how do i whitelist the wemod exe’s?

Here’re instructions direct from a KB article off McAfee’s site:

It still does not work. Is it possible my college is blocking it? Because I tried on my laptop which doesn’t have any AV and on my friends computer and it says the same thing. It won’t load the link on those other computers as well.

It’s possible that your college has another layer of security that is beyond your control, yes.
Someone else in the forum recently had an issue with their college blocking WeMod from downloading, but they were able to get past it by using a VPN.

Could you try a VPN? If not, try taking your laptop somewhere with free public WiFi, like a restaurant or library outside of your college, to download WeMod.

good

Yes it was my school blocking it. I got a vpn to download it thank you everyone!!

1 Like

Glad you got this resolved!

:slightly_smiling_face: