Won't install due to .NET framework

So, I’ve attempted to download the app more than once in the last week, and every time I get the following error message: “Installation has failed. Failed to install the .NET Framework, try installing the latest version manually.”

I, of course, tried to do that, but I already apparently have the most up-to-date .net framework microsoft offers on it’s website. I’ve tried disabling my antivirus and my firewall temporarily to no avail either time. I’m completely out of ideas so any help is welcome.

What windows are you on and what .Net framework do you have?

You’ll need .net framework 4.7.1, if you’re on Windows 7 you’ll need Service Pack 1 before you can install .net 4.7.1

1 Like

I have Windows 10 and I had 2.3.1, but any updates I try to install also failed.

Unfortunately we cannot help with Windows related issues only issues with WeMod. There are far too many things that could be going on. I’d just make sure you’ve done all relevant windows updates :slightly_smiling_face: