"Wrong DLL present"


I usually never have a problem with Infinity with my games. Although for Rise of Tomb Raider, it says when I open it with Infinity “An Error has occured while loading imports. Wrong DLL present.”

Can’t use Infinity with this game. Can somehow help me to fix the issue, please? :slight_smile:

It’s possible you are running the 32 bit version of the game. Infinity only supports the 64 bit version.

Thanks Frank for answering but it didn’t help :frowning:
I reinstalled Rise of Tomb Raider + Infinity just in case too. So weird because it doesn’t do it on other games

You should be able to check the process in the task manager (ctrl+shift+esc) to see if the game is running in 32 or 64bit (think it says “*32” next to the name if it is running in 32bit).

It’s 64bits and somehow it works on my friend’s PC but not on mine. I’m on Windows 7, he’s on W10. Maybe it’s the reason why?

Infinity works for both windows 7 and 10 so it is probably something else. Maybe your antivirus or firewall are blocking something?

Both disabled. Weird it’s working on someone’s PC but not mine D:

I am having the same exact issue. i am running 64 bit game and getting the same error. also have my antivirus blocked and same error every time

Which game?

im having the exact same issue. only with ROTTR. nothing is working. reinstalling both the game and infinity. antivirus and 32/64 bit option.

@Arwenda have you fix the issue on ROTTR we have the same problem it wont run on Infinity

I know it works fine for me . Do have the game from steam ? Latest update ?

What if you start the game first then start infinity after ?

@ptondo just the same issue i tried everything start the game first then run infinity… i also disable my anti virus but if you played without suing infinity it works fine